Good morning all.

I bought a [used] Performer, and I am having trouble with the propane ignition. I attached brand-new propane tank, cleared the kettle of any used coals, debris, ash, etc. I clicked the ignition switch several times, but it does not light. I smell the gas, but nothing happens.

Any suggestions on what might be causing this?

Thanks in advance.
Stupid question - how do I check to see if this is the case?

best place to buy one?
Try lighting it with a lighter when the propane is turned on. Also try to clean out the burner tube. I doubt its the igniter, it could also be the regulator. All these items can purchased online. Start with trying the lighter, also, what generation Performer do you have, post a pic if you can.
Last edited:
Good point Pat, yes which type of ignitor do you have the large chrome button(battery) or the red snap type?
A lot of times the end wires just get dirty and need cleaning to make good contact or ground to spark.
The battery type I would replace to the battery and inspect the battery contacts to remove any green growth or corrosion white flaky stuff. Then see what happens. For parts Amazon, and several grill web sites carry lots of good parts.
2 Types of Ignition on Performers. Newer Electric with Battery type on left and older Mechanical type on right.

2 Ignition types on Performers.jpg

In either style, check wire connection to button and also the connection to the tube the flame comes out.

1. Electric with Battery (on newer gen Performers): When it functions properly, it should make a series of quick, quiet electric sounding snaps as long as you hold down the button. Make sure battery is fresh. Make sure positive nipple end of battery that goes into the hole of the electric housing box. Make sure the contact inside hole of electric housing is not corroded and same for contact inside rubber button (corrosion can be scraped clean). I had a problem on a newer gen Performer that I flipped where inside the rubber button (negative end of battery) the contact was broken so I fixed it by putting folded aluminum foil inside button to continue the electrical current.

2. Mechanical (SSP and older gen Performers). It should make a loud snap sound each time you push button all the way down. If it does not, time to get a new one. This ignition type is very durable.

I liked the Electric with Battery from the new gen Performer so much that I ordered a new one from Weber and installed it on my 25 year old SSP as pictured above. I like the quiet start and how it immediately ignites. My 25 yr old mechanical button still worked but always took several pushes and I didn't like the noise.
It’s always worth blowing out the spiders and soot from the burner tube. One of my Performers the previous owner never used the gas assist, in fact the yellow plastic cap was still on the propane attachment, it it was still full of stuff keeping the gas from reaching the outlets. A bit of compressed air was all it needed. (Probably should be an annual maintenance ritual.)
If the igniter is sparking, then Bob has the solution. Even if it looks clear, run something up through the tube to clear out any debris or insect stuff.
What about this problem - Performer/Gen 3 w/ piezo igniter

The tube is nice and clean-
When you try to light it- the flame can be seen inside the tube
right where it connects to the hose, about 1/2 inch from the orifice.
However, no flame is actually coming out the other end inside
the kettle.
I have tried 2 different tanks so far.
Orifice probably has something in it, pretty easy to pull out and clean.
The orifice was nice and clean also. I swapped out the regulator w/ a spare that I have
and that fixed the problem.
Now I am wondering if there is a way to repair the regulator.
Dave, glad you got it fixed. I don't remember how the hose/regulator is set up on those grills but I assume you can't simply buy a standard grill regulator hose off the shelf for it.

Otherwise, you might want to examine the old one to see if you can take just the regulator out of the hose and then steal a regulator from a standard hose and swap that in. But, I don't think the regulators are generally a serviceable item themselves.
Hi Dave, I have an older weber performer I bought about 25 years ago and love it, but have also had similar issues. I have had to replace the regulator - you merely need to call weber and you can order a replacement from them. I have also replaced the igniter mechanism which I also got directly from weber.

I too have the occasional problem of the gas not igniting. My remedy has been to use a piece of cloth attached to a stiff wire to swab out the gas feeder that goes into the kettle; and sometimes I use my wet dry vac to suction out the gas feeder because of charcoal dust that can get in the line. I then use a lighter to manually light the feeder. Usually after these steps the manual lighter button works fine because whatever was blocking the sparks has now been either wiped away by the cloth, sectioned away by the vacuum, or burned off by the heat from the lit flame. Still, I always check to make sure the igniter button does ignite the gas before I pile my charcoal above the gas line - in case I need to use an external flame to ignite the gas.