LinkMeter v2 Homebrew BBQ Controller - Part 2


 

John Bostwick

TVWBB Wizard
@Kyle Get multi-meter and using the scemantic and the continuty checker on the meter go from the probe that is giving you the problem and start checking for shorts or things that are not connected(soldered) firmly.

Its the easiest way to check to make sure all is good before giving it the power.


And I too have a problem with mine that has me perplexed atm.

Router gets the info from the heatermeter and I can see it displayed on the internet webpage and works fine until I try to change something on the heatermeter.

Its like its in read-only mode and all inputs by me are getting are getting rejected. I type in the heat on either graph display or in the config. page and it will stay what I type until the page is updated.

The graph is fine and it gets updated with the correct info from the probes. I can only change the temp on the button board.


It worked fine earlier, and this is why it has me stumped, on more thing, on the config. page it had a "Full configuration URL" posted when I would look at the page now it only has the SP for the pit probe and nothing else is listed
 

Kyle Stierwalt

New member
Thanks, will do.

Originally posted by John Bostwick:
@Kyle Get multi-meter and using the scemantic and the continuty checker on the meter go from the probe that is giving you the problem and start checking for shorts or things that are not connected(soldered) firmly.

Its the easiest way to check to make sure all is good before giving it the power.

---snip----
 

Bryan Mayland

TVWBB Hall of Fame
Originally posted by Kyle Stierwalt:
Thanks, reflashing did fix my LCD issue. Everything is working except I've just encountered a strange behavior and it's a show stopper. When I plug my pit probe in the LCD goes blank and all the lights on the router come on requiring me to remove the pit proble and power on/off. I disconnected the PCB from the router and powered it by the 12v barrel jack and when I plug the pit probe in under this setup the LED will blink and the LCD will flash quickly and then this repeats over and over. Short somewhere?
That is definitely a short somewhere. Seems the overcurrent protection kicks in and powers down the device then turns back on shortly, and repeats. I'd suggest unplugging your probe harness then putting a 10k resistor across one of the pins and ground (ground being pin 1). If the probe is configured for the vishay preset then it should read 77F. If that works, then reconnect your probe harness and try placing the resistor between the "data" pin and the ground pin and you should get the same results.
 

Bryan Mayland

TVWBB Hall of Fame
Originally posted by John Bostwick:
Its like its in read-only mode and all inputs by me are getting are getting rejected. I type in the heat on either graph display or in the config. page and it will stay what I type until the page is updated.

It worked fine earlier, and this is why it has me stumped, on more thing, on the config. page it had a "Full configuration URL" posted when I would look at the page now it only has the SP for the pit probe and nothing else is listed
That's what it looks like when the linkmeterd can't transmit to the HeaterMeter board (it can't send "/config"). For some reason your serial sends aren't getting received by the AVR.
 

Dennis C

TVWBB Fan
Plugged everything in today.

The LCD lights up but nothing is displayed on it. I have the probes and pit plugged in and when to I go to 192.168.200.1 the probes show as off the setting is set to internal for the probes.

I then tried to reflash the firmware and get this message when I try to flash it through the router

1051f2a9d6410072d44e2a47260f1217 /tmp/hm.hex
Stopping LinkMeter OK
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: stk500_getsync(): not in sync: resp=0x24
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: compiled on Feb 15 2012 at 15:43:06
Using port: /dev/ttyS1
Loading ihex file: "/tmp/hm.hex" (21948 bytes)
Starting sync (release RESET now)...
Sync: ERROR
Sync: ERROR
Sync: HeaterMeter
Sync: ERROR
Sync: ERROR
Update failed
Starting LinkMeter OK
Current HeaterMeter version is 20120527B

Just to confirm I'm hooking this up to the bottom 5 serial slots on the router? I've seen some people with stuff in other spots so just want to make sure I did it right
wrt54gv3_inside2_196.jpg
 

Bryan Mayland

TVWBB Hall of Fame
Yeah you've definitely got it hooked to the right spot because where it says "Current HeaterMeter version is 20120527B" in your output, that means that the router is receiving version information from HeaterMeter. Also the "Sync: HeaterMeter" indicates that hmdude detected that the AVR wasn't in the bootloader and that the HeaterMeter program was running.

You may want to try running the update manually with verbose mode and seeing what you get. Log into the router over ssh/telnet and

cd /tmp
/etc/init.d/lucid stop
wget -O hm.hex http://capnbry.net/linkmeter/s.../heatermeter.cpp.hex
hmdude -v -v -v -v -U hm.hex

You can also check to see if your AVR has the old bootloader on it by replacing that last line with the lower baud rate
hmdude -v -v -v -v -U hm.hex -b 57600

If neither of those work, try hmdude (with the normal baud rate) except this time hold down the RESET button on the HeaterMeter and then press enter on the hmdude command and release RESET when it says to. If that works that would indicate your reset circuit isn't working.
 

Dennis C

TVWBB Fan
I must have erased the bootloader and software from the atmega

I get this now. When I hit the reset button I still kept getting the errors. I probably have to use the audrino uno again to program the chip as it didn't work with the usbtiny

Connecting to capnbry.net (24.73.193.140:80)

hm.hex 10% |*** | 6754 0:00:08 ETA
hm.hex 100% |*******************************| 61758 0:00:00 ETA
1051f2a9d6410072d44e2a47260f1217 /tmp/hm.hex
Stopping LinkMeter OK
hmdude: compiled on Feb 15 2012 at 15:43:06
Using port: /dev/ttyS1
Loading ihex file: "/tmp/hm.hex" (21948 bytes)
Starting sync (release RESET now)...
Sync: ERROR
Sync: ERROR
Sync: ERROR
Sync: ERROR
Sync: ERROR
Update failed
Starting LinkMeter OK
Current HeaterMeter version is Unknown


Also getting this when I did the hm.hex way

root@OpenWrt:/tmp# hmdude -v -v -v -v -U hm.hex -b 57600
hmdude: compiled on Feb 15 2012 at 15:43:06
Using port: /dev/ttyS1
Loading ihex file: "hm.hex" (21948 bytes)
Starting sync (release RESET now)...
hmdude: Send: . [0a] / [2f] r [72] e [65] b [62] o [6f] o [6f] t [74] . [0a]
hmdude: Send: 0 [30] [20]
hmdude: Send: 0 [30] [20]
hmdude: ser_recv(): programmer is not responding
Sync: ERROR
hmdude: Send: 0 [30] [20]
hmdude: Send: 0 [30] [20]
hmdude: ser_recv(): programmer is not responding
Sync: ERROR
hmdude: Send: 0 [30] [20]
hmdude: Send: 0 [30] [20]
hmdude: ser_recv(): programmer is not responding
Sync: ERROR
hmdude: Send: 0 [30] [20]
hmdude: Send: 0 [30] [20]
hmdude: ser_recv(): programmer is not responding
Sync: ERROR
hmdude: Send: 0 [30] [20]
hmdude: Send: 0 [30] [20]
hmdude: ser_recv(): programmer is not responding
 

Brian J Wilson

New member
Kyle,

I had a similar problem that was caused by installing the fan diode backwards.

-Brian

Originally posted by Kyle Stierwalt:
Thanks, reflashing did fix my LCD issue. Everything is working except I've just encountered a strange behavior and it's a show stopper. When I plug my pit probe in the LCD goes blank and all the lights on the router come on requiring me to remove the pit proble and power on/off. I disconnected the PCB from the router and powered it by the 12v barrel jack and when I plug the pit probe in under this setup the LED will blink and the LCD will flash quickly and then this repeats over and over. Short somewhere?

Thinking I will solder up a new probe "string" and see if that fixes the issue. Anyway, if anyone else has run into this please let me know, or if you have suggestions on troubleshooting I'd greatly appreciate it.

Thanks, almost to the homemade stoker promise-land.
icon_smile.gif
 

Bryan Mayland

TVWBB Hall of Fame
Originally posted by Brian J Wilson:
I had a similar problem that was caused by installing the fan diode backwards.
This is a great suggestion, if that diode is reversed, as soon as the device boots and gets its first probe reading, which is below the default 220F setpoint, it tries to turn the fan on and immediately shorts 12V to ground which will kill the power.
 

Tom Kole

TVWBB Pro
I assembled my linkmeter and heatermeter today and it is working beautifully except for one thing. I tried to flash the firmware via the linkmeter web interface and got the following output:

1051f2a9d6410072d44e2a47260f1217 /tmp/hm.hex
Stopping LinkMeter OK
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: stk500_getsync(): not in sync: resp=0x24
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: compiled on Feb 15 2012 at 15:43:06
Using port: /dev/ttyS1
Loading ihex file: "/tmp/hm.hex" (21948 bytes)
Starting sync (release RESET now)...
Sync: ERROR
Sync: ERROR
Sync: HeaterMeter
Sync: ERROR
Sync: ERROR
Update failed
Starting LinkMeter OK
Current HeaterMeter version is 20120628B

The linkmeter is definitely communicating everything else is working. What could be causing this? Also, on the AVR firmware update page, when I select "from online repository" I get an "error no transport" message. Is there an address that I need to update to point to the online file repository?
 

Dennis C

TVWBB Fan
Originally posted by Tom Kole:
I assembled my linkmeter and heatermeter today and it is working beautifully except for one thing. I tried to flash the firmware via the linkmeter web interface and got the following output:

1051f2a9d6410072d44e2a47260f1217 /tmp/hm.hex
Stopping LinkMeter OK
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: stk500_getsync(): not in sync: resp=0x24
hmdude: stk500_getsync(): not in sync: resp=0x0a
hmdude: compiled on Feb 15 2012 at 15:43:06
Using port: /dev/ttyS1
Loading ihex file: "/tmp/hm.hex" (21948 bytes)
Starting sync (release RESET now)...
Sync: ERROR
Sync: ERROR
Sync: HeaterMeter
Sync: ERROR
Sync: ERROR
Update failed
Starting LinkMeter OK
Current HeaterMeter version is 20120628B

The linkmeter is definitely communicating everything else is working. What could be causing this? Also, on the AVR firmware update page, when I select "from online repository" I get an "error no transport" message. Is there an address that I need to update to point to the online file repository?

If you scroll up a bit you will see I have the exact same problem. Bryan suggested a few steps to try. Didn't work for me, but you might give it a try.

Also you are most likely not connected to the net on your router. You are getting a basic 192.168.200.1 static address. I Maje network changes in the config and was able to get online.

I'm still trying to figure what to try next. I am busy today so won't get much time to play
 

Kyle Stierwalt

New member
Yep! That's it exactly. Good catch, thanks.

Originally posted by Brian J Wilson:
Kyle,

I had a similar problem that was caused by installing the fan diode backwards.

-Brian

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Kyle Stierwalt:
Thanks, reflashing did fix my LCD issue. Everything is working except I've just encountered a strange behavior and it's a show stopper. When I plug my pit probe in the LCD goes blank and all the lights on the router come on requiring me to remove the pit proble and power on/off. I disconnected the PCB from the router and powered it by the 12v barrel jack and when I plug the pit probe in under this setup the LED will blink and the LCD will flash quickly and then this repeats over and over. Short somewhere?

Thinking I will solder up a new probe "string" and see if that fixes the issue. Anyway, if anyone else has run into this please let me know, or if you have suggestions on troubleshooting I'd greatly appreciate it.

Thanks, almost to the homemade stoker promise-land.
icon_smile.gif
</div></BLOCKQUOTE>
 

John Bostwick

TVWBB Wizard
icon_smile.gif
I recieved a new wrt54g V2 in the mail last night and this morning wired it up, without problems.

Everything is working.

For some reason the v3.1 router, I had stopped transmitting on the TX line. Could not get it to work.

I have the new one up and running, doing a stress test to make sure it stays going until I wake up for work.
 

Tom Kole

TVWBB Pro
Originally posted by Dennis C:
If you scroll up a bit you will see I have the exact same problem. Bryan suggested a few steps to try. Didn't work for me, but you might give it a try.

Also you are most likely not connected to the net on your router. You are getting a basic 192.168.200.1 static address. I Maje network changes in the config and was able to get online.

I'm still trying to figure what to try next. I am busy today so won't get much time to play

I saw that after I posted. I tried that and got the same exact results as you. I don't know how much I should pursue this since the device is working after all. I guess I'll give reloading the boot loader a ty to see if that does anything.

I tried changing the network settings on the router to connect to the online respository but ended up locking myself out of the router and having to go into failsafe mode to get things working again. I guess I'll leave that be for now.
 

Dennis C

TVWBB Fan
Originally posted by Tom Kole:
I tried changing the network settings on the router to connect to the online respository but ended up locking myself out of the router and having to go into failsafe mode to get things working again. I guess I'll leave that be for now.

When you change the network settings the 192.168.200.1 should change to something on your network. I downloaded a LAN scan and saw the correct ip and was able to log in
 

Tom Kole

TVWBB Pro
After re-burning the bootloader the lcd would no longer light up and I could not flash via the web interface. I ended up reflashing via the usbtiny and everything works again except for the web flashing.

Dennis, did you just change the static address of the lan to match the subnet of your network. I have the router as a client via wireless and it is assigned an address on the subnet. So all I need to do is change the lan address manually?
 

Dennis C

TVWBB Fan
Originally posted by Tom Kole:
After re-burning the bootloader the lcd would no longer light up and I could not flash via the web interface. I ended up reflashing via the usbtiny and everything works again except for the web flashing.

Dennis, did you just change the static address of the lan to match the subnet of your network. I have the router as a client via wireless and it is assigned an address on the subnet. So all I need to do is change the lan address manually?

Changed mine to DHCP and let the main house router assign the IP to the second router
 

Tom Kole

TVWBB Pro
Originally posted by Dennis C:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Tom Kole:
After re-burning the bootloader the lcd would no longer light up and I could not flash via the web interface. I ended up reflashing via the usbtiny and everything works again except for the web flashing.

Dennis, did you just change the static address of the lan to match the subnet of your network. I have the router as a client via wireless and it is assigned an address on the subnet. So all I need to do is change the lan address manually?

Changed mine to DHCP and let the main house router assign the IP to the second router </div></BLOCKQUOTE>

The linkmeter is assigned an ip address by my home router as a wireless client (wwan). Under network settings, the linkmeter lists the following conncetions:

lan ip address 192.168.200.1
wan (not used)
wwan (wireless) ip address 192.168.10.125

Do I need to bridge the lan and wwan connections?
 

Dennis C

TVWBB Fan
For my purpose I wired the connection directly to the router. I didn't get far enough to do the bridge or anything since my heater meter is not working correctly at the moment.
 

Bryan Mayland

TVWBB Hall of Fame
You do not want to plug the wired subnet into your home network without disabling the "dnsmasq" service. This is a DHCP and DNS server and if you have two on your network then when another computer tries to get an IP, there's no telling who it will get it from and then you'll have all sorts of networking headaches.

You also should not bridge the lan and wwan if you're going to put the wireless on your existing wifi while leaving the lan assigned to 192.168.200.x, because that's two subnets on the same device and OpenWrt doesn't like that.

Finally, you can't bridge the wwan to wan because that's explicitly disallowed (I'm not sure why but it was added upstream last year).

To attach the Linksys as a client to your existing wifi:
-- Start from a default config, changing one thing often changes multiple things so don't think you can work your way back to default unless you restore the config files.
-- Plug a network cable into the wired ports on the router, and the other end into your computer.
-- Connect to http://192.168.200.1
-- Go to the wireless configuration, enable the wireless, do a scan, then join your network, entering the security information needed.
-- Save and Apply.
-- It will say please wait and that won't ever go away so give it a minute then pull the power and restart. It should connect up to your wireless and you can find it by going to http://openwrt
-- Some fancy browsers will do a search engine search for "openwrt" if you don't include the http://

Also please start new topics when posting a new problem. This thread is 100 pages long and the networking config has been discussed probably 5 times but I can't find it because the thread is 100 pages long!
 

 

Top