INTRODUCING: the "Roto Damper"

RalphTrimble

TVWBB Diamond Member
Thanks for posting the wiki link showing the CAT5 wiring Bryan, I have added a link to that in the appropriate place in the first post of this thread. I have to admit I haven't perused the wiki in quite a while....
 

BrianDickens

New member
Ralph, I sent you an email on this but maybe it's good to have here as well. Do you have suggestions for printing the body? The dovetail isn't printing great for me. I used supports for it and it's not fitting into the wiring box.
 

Bryan Mayland

TVWBB Hall of Fame
Thanks for posting the wiki link showing the CAT5 wiring Bryan, I have added a link to that in the appropriate place in the first post of this thread. I have to admit I haven't perused the wiki in quite a while....
That's ok, nobody peruses the wiki! :) I can understand why though after looking at that page, it is difficult to understand because there's too many options presented as text when 99% of people will be doing it the same way so there should be a better illustration. I was also unsure about the wire colors at the time so it is vague, but I've made 4 or 5 dampers for friends or friends of friends now and now am more confident about what color the wires should be so I just need to figure out how to do a colored table in markup to make it a little clearer.
 

Steve IL

New member
Hi Ralph i don't have a 3D printer i was hoping I can pay you for the parts and shipping for a roto damper? I got one from you last year but need another for a friend. Let me know if you can help me out. Thanks
 

RNMixon

New member
My first two burns with the RD3 were great. But the last burn, not a long one just grilling some corn and dogs, I noticed it was running hotter than it should. When I shutdown I noticed the RD3 was stuck open.

I hooked it back up in side but could not get it to respond. When I took it apart the servo was still quite hot and the labels on both sides had peeled up a bit.

Luckily I had bought two servos so I put the backup in place. This one seems erratic. I'm using the calibration steps in this link (https://tvwbb.com/showthread.php?46004-INTRODUCING-the-quot-Roto-Damper-quot&p=569948&viewfull=1#post569948).

I adjusted the servo pulse durations to 700 and 2380 so it would open fully at 100% and close at 0%. But then about the second time I go back to 100% it opens fully, but decreasing the percentage does not cause it to close - which sort of matches with the experience on that burn with the damper not closing when it was told to. If I try a few minutes later it's back working for a time or two.

I've tried this with both the the cover in place and with it off and just the servo horn in place. Is there something I'm missing maybe? or was it just a couple of bad servos?

Also, I tried to glue the arrow and lines on with super glue like one posting recommended but they did not stick. Is there a particular kind of super glue to use with 3-D printed stock?

Thank you - Richard
 

RalphTrimble

TVWBB Diamond Member
Sounds like you have a loose wire for the servo somewhere to me...
Do you need to really press the servo into the RD3 or does it fit easily? If it is too tight the servo may bind, loosen up the slot a bit with a file or knife or something if that is the case.... or try it with the servo completely out of the RD3 body to eliminate the possibility of binding.
When calibrating did you follow the steps and make sure you are not exceeding your servo's range on the high and low ends? If you peg the servo to one end or the other it may bind and overheat as you describe, 2380 seems like it might be on the far end for the servo, I would check that side.
As for glue, any super glue should work, I have used lock tight and gorilla super glue, it generally kinda melts the ABS as it is applied due to presence of acetone I do believe. I find the easiest way to attach the arrow and lines is to stick them to small pieces of tape, apply glue, then stick in place with the tape. Once the glue dries remove the tape.
 

Bryan Mayland

TVWBB Hall of Fame
+1 to the thin CA glue. I use Super Glue brand when I glue my ABS stuff together, mostly because I bought a box of 10 tubes or something and still haven't gotten through it all. It doesn't seem to want to stick and it just slides around but once the glue dries it holds pretty well so it just needs to be held it place with tape until it does. Hot glue also works ok, but it will show on the sides since you need a bit more to hold so it squeezes out. If you go that route be aware that if you put hot glue on the tiny arrows, they will soften pretty quickly from the heat so it is best to apply the glue to the RD3 then place the arrow on it.

It does sound like the damper is either binding up or the servo is going loco and since you say it does it without just the servo arm in place, have you tried adding a capacitor to the servo side of the HeaterMeter output cable? It seems to settle out the majority of weirdness in these cheap servos at the end of somewhat long cable runs.
 

RNMixon

New member
RD3 still sticking

Ralph and Bryan - thank you both for the responses.

So I trimmed the servo and fan wires as short as practical, stripped the ends and re-tinned them. Then punched them down properly in the RJ45 jack,

I inspected the rotating and static parts of the damper. It looked like there might be tiny bit of superglue from when I tried to put the markers on - but it was really slight, just a shine really. Nevertheless I took a fine emery board and polished both sides - no abrasions, just polish.

Did a short beer can chicken burn today and the problem re-appeared. After about a half hour I notice the temp going up. I look and the HeaterMeter reads 0% but the damper is open about 1/3. I switched the fan to manual and it still would not respond. I nudged it a bit and it moved some more. Finally cranked it back up to 100% and then it started to respond. Things seemed to be working so I proceeded with the burn, but then it happened two more times.

Attaching two pics showing the HeaterMeter and the RD3 at the point the damper stuck.

Two thoughts - but open to any other ideas.

First, might as well add that the ambient temperature was 109 here in Phoenix when I did todays burn. Any chance that's playing havoc with alignment on the damper?

Second, how about the servo - could the heat be too much for it. I'm using Tower Pro MG90S services. Just in case that's the issue I ordered a batch of a different brand of MG90W servos off of Amazon - TIANKONGRC - hope they are not any worse. Neither of them list environmental specs.

BTW, my son used the plastic cement he uses for miniature figures to glue on the arrow and indicator bars and they seem to be holding fine. I'll try and remember to get the name of the glue.

Thanks again for the support and community.

- Richard



 

RNMixon

New member
After a bit more searching I did find temperature specs on HobbyKing.com for similar servos listed as 0-55 Celsius - so theoretically the servos can take that heat.

  1. https://hobbyking.com/en_us/turnigytm-mg90s-ds-mg-servo-1-8kg-0-10sec-18g.html
  2. https://hobbyking.com/en_us/towerpro-mg90d-mini-digital-servo-2-4kg-0-08sec-13g.html
One more question about what is "too tight". Reading the posts on this thread the guidance is to be sure and not overtighten the screw that holds the servo horn in place. I've been tightening until it started to provide resistance and then backing off a turn. Is that about right? I worry about the screw being too lose and the damper coming off - is loctite or anything like that needed?

Assuming it's not too tight, is there anything that can be done to make the damper door provide less frictions. I see that lube/grease is not recommended when it's cold outside - how about when it's over 100?

- Richard
 

RalphTrimble

TVWBB Diamond Member
Since the screw rotates with the servo horn (and gear beneath) the screw will not work loose no matter how lightly you tighten it, no need for loctite. If you are concerned that it is too tight test the motion without the screw installed and see if it still sticks?
Over the past number of years I have never had someone report a friction issue that required lubricant. Perhaps you should wash both disc's that make up the damper to be sure there is nothing sticky on there? Perhaps things tighten up after exposed to such heat? Though I have sent dampers to Arizona, Texas etc and never had anyone report an issue with the heat...
Post a picture of the damper with the damper disc removed, I am interested in how the servo shoulder is sitting in there...
 
Last edited:

RNMixon

New member
Well the issue was not the damper plate or how tight the screw was. When I took the servo out of the case it still would stick every other time at about 25 - 30 percent.

I replaced it with a different brand of servo that seems much, much smoother and also has not stuck once so far. Been outside in the heat all morning.

So either the batch of two "TowerPro" brand MG90S servos were bad or that model is bad. Anyway, for me they are black-listed and the TIANKONGRC brand are on the white list.

Thanks again and hope this helps someone.

Thanks - Richard
 

RNMixon

New member
Exactly! Yes, the two on the left are the ones that went bad. The one on the right, labelled "TIANKONGRC", seems to be much better.

[/IMG]

It would not fit the keyhole slot, so I had to use a small rat tail file and relieve it a bit.

But works fine. I'll be sure and post some negative feedback to the seller on Amazon for the first two - though since I've cut then leads I probably can't return them.

Thank you again - Richard
 

David Disney

New member
Hello everyone, I’m just checking in here as I’m about to start building a HeaterMeter and hopefully an RD3. Looks like a really cool project.
 

David Disney

New member
Just wanted to say thanks to everyone, especially Ralph for sending me a copy of the STL files.

I printed everything last week and built my HeaterMeter and RD3 last Sunday morning. I fired up the BGE a little after lunch and played with the HM/RD3 setup. It pretty much worked perfectly out of the box; all I had to change was the servo setting to get full open/close. It held perfectly at 195, 200, 225, and 250. Then I smoked some salmon for dinner using the new setup and got a text message when it was ready ;)
 

MilesB

New member
I joined just to post on this thread.

Have made a HM4.2 which appears to work fine. It's primary use is on my 55gal UDS, which has two 1.5in inlets.

1. Will this fit "off the shelf"?
2. Do I need to get the control board that goes with it, or can I just plug it straight into the HM?

Can't wait to get started! Really enjoyed building the HM4.2.
 

RalphTrimble

TVWBB Diamond Member
I have various output adapters for the RD3 to suite many scenario's, the largest being 1" Female NPT threaded.
You can run the RD3 with just the CAT5 jack connecting the servo and blower to the HM without the RDTC board in the RD3, the aux board is an option not a requirement.
 

MilesB

New member
Thanks Ralph,

I guess the cheap solution is to use high temp tape with the largest adaptor going until I can come up with a better way of doing it. I sent you an email - how do I get the STL files?
 

Top