Not able to embed YouTube videos


 

CaseT

TVWBB Diamond Member
I’ve been trying to embed YouTube videos and when I do I get an error message saying it can’t embed the the video. Using iPhone 11

185D4F06-C12C-4AC4-B009-84A063CAAAA8.png



FA858374-6ED3-48C8-8AE4-74520B0CB2B0.png
 

CaseT

TVWBB Diamond Member
Use the link copy function. Than paste the link into your post
That’s what I’ve resorted to, but then just the link shows up. The embed feature actually puts the video right there. Works on other forums using the same platform. Used to work here too until the site upgrade.
 

Lynn Dollar

TVWBB Emerald Member
YT has two links that are slightly different, the one in address window is a bit different from the one under the " share " function . IDK if it makes a diff .
 

timothy

TVWBB Olympian
Yea I click on the Share button copy that link and paste it in my post.
It automatically embeds it.
 

CaseT

TVWBB Diamond Member
YT has two links that are slightly different, the one in address window is a bit different from the one under the " share " function . IDK if it makes a diff .
So no probelm embedding from the computer using the medai insert tab and the youtube link. Only happening when I try to use it on my Iphone which is where I post fron 99% of the time.
 

Chris Allingham

Administrator
Staff member
The forum software doesn't like "shorts" in the URL. This may be one of the new YouTube Shorts videos designed to compete with TicTok.

The forum software expects these two formats.

Code:
https://www.youtube.com/watch?v=ZG4CfrmVSwE
https://youtu.be/ZG4CfrmVSwE


 
Last edited:

CaseT

TVWBB Diamond Member
The forum software doesn't like "shorts" in the URL. This may be one of the new YouTube Shorts videos designed to compete with TicTok.

The forum software expects these two formats.

Code:
https://www.youtube.com/watch?v=ZG4CfrmVSwE
https://youtu.be/ZG4CfrmVSwE


Hmmm, yeah it seems to only grab the short when I use my phone. I'll have to play with it some more to try and get the link. It only startred happening recently so you may be right. Damn Tick tack paddy whack.
 

Chris Allingham

Administrator
Staff member
Not clear how popular YouTube Shorts will become, but if it really takes off, I'm sure the forum software folks will include this in a future update.
 

CaseT

TVWBB Diamond Member
Not clear how popular YouTube Shorts will become, but if it really takes off, I'm sure the forum software folks will include this in a future update.
So after doing more experiments from the phone or iPad when using the YouTube app the only share option now is the shorts link. If you want to grab the traditional link you have to access YouTube through a browser. Which makes it a pain if you use your phone or iPad and apps. Hopefully the forum platforms will start to allow the shorts links as I have a feeling they are here to stay. Unfortunately means due to the process to get the link I won’t post videos here anymore unless I’m on my computer which isn’t often unless I’m working.
 

Chris Allingham

Administrator
Staff member
How are you grabbing these shorts URLs? Posting this example from my iPhone using YouTube in the browser. The URL appears to be the usual format.

Code:
https://youtu.be/doC4UOueUrU

 
Last edited:

Chris Allingham

Administrator
Staff member
Good news today from Xenforo. Thanks to @CaseT for bringing this to my attention.

Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.6).
 

 

Top