HOWTO: Configuring LinkMeter WiFi


 

Bryan Mayland

TVWBB Hall of Fame
While OpenWrt (the basis of the LinkMeter operating system) is traditionally used in routers as an access point, most will find it more convenient for their HeaterMeter to be a device on their home wifi network instead of being its own standalone network. If you can't wrap your head around what "being a device on your network" means, it means you can access LinkMeter to watch your BBQ from any machine your home network without jumping through any hoops or changing your network settings.

Step 1: Plug the wired ethernet connection into you RaspberryPi / HeaterMeter, insert your WiFi adapter into one of the USB ports, and power it up. On first boot there's a lot to do so give it a minute to make sure the system is fully booted. A minute is nothing. I used to wait 10 minutes to download a 320x240 image of a topless woman at 2400 baud and I still feel that was worth it.

Step 2: From a computer on your network change your IPv4 address to 192.168.200.2. Depending on your operating system this could be anywhere, because Microsoft likes to invent a jaunty new place to put it with every version, and Apple doesn't think you need to be mucking with this sort of information.
hm-wifi-0.png


Step 3: Use a web browser to go to http://192.168.200.1/ which should land you on the HeaterMeter home page. It's blue. It has flaaaaames. It's pretty American. (No photo, you'll know it when you see it)

Step 4: Click the configuration link on the bottom of the page then navigate to Network -> WiFi and click Scan. If there is no WiFi listed, either your WiFi adapter is not supported or you don't have a power supply capable of providing enough power to the wireless adapter.
hm-wifi-1.png


Step 5: Find your wireless network and click Join. My name is lame. Yours I'm sure is hilarious and expresses your individuality.
hm-wifi-2.png


Step 6: Enter your wireless password. I'm guessing it is "12345"!
hm-wifi-3.png


Step 7: Don't touch a cotton pickin' thing on the page that comes up. You're not smarter than the defaults or else you wouldn't need this guide. Just press "Save and Apply"
hm-wifi-4.png


Step 8: This is where you think things have gone wrong because the "Waiting for changes to be applied..." never goes away. I don't know what it is waiting for, perhaps a new pope to be elected. I've never waited that long. Just wait 15 seconds and move on.
hm-wifi-5.png


Step 9: Navigate to Network -> Interfaces. You should see you're on your wifi network now and you can see the IP address on your home network you can use to see the LinkMeter site. I'm not good with numbers so I like to use a name. To use a name, click "Edit" on the wireless network
hm-wifi-6.png


Step 9: Enter a name. I like short names "hm", "hmpi", or "bob". "Save and Apply" to commit the change. You'll get our old friend the "Waiting for changes..." pope-watcher but rest assured next time this puppy boots it will register on your home network with that name. Not all routers support named DHCP registration so if it doesn't work, use the IP address from the previous step 9.
hm-wifi-7.png


You can now change your computer's IPv4 address back to DHCP and should be able to access the LinkMeter site (after rebooting once) via http://thenameyouchosewhichishopefullyshorterthanthis/

IMPORTANT Don't change the wired ethernet configuration on the RasberryPi. If you change that interface to DHCP or give it a static address on your network, the WiFi won't work unless the wired ethernet is plugged in. This is because you've put two adapters on the same network and Linux doesn't know which you want the packets to go through without you setting up that configuration properly.
 
Last edited:

Jason J

TVWBB Fan
Hi Bryan,

I am having some issues with wifi on this. It is actually very weird. If I just have the wifi plugged in, it will eventually get the IP address 192.168.1.69 as dictated by my router (I have it set to a fixed IP on the router). However, I cannot ping or access the device using that IP address. If I plug in the wired ethernet, it pulls the IP address 192.168.1.1. At this point I can ping BOTH ip addresses including .69 wireless.

I can then disconnect the wired connection and the wireless works just fine. But anytime I reboot or unplug the device, the wireless does not work until first plugging in the wired connection. Here are some screenshots of my setup.

Router setup:

static assignment.jpg


Interface overview:

interfaces.jpg


Edit Interface:

edit interface.jpg


Now this screen is odd. It says the IP address is ?.

wifi.jpg


Sooo why would the wireless interface only work after the wired one is plugged in?
 

Bryan Mayland

TVWBB Hall of Fame
Sooo why would the wireless interface only work after the wired one is plugged in?
You can't have both adapters on the same subnet. Even worse, DHCP sets the wired ethernet as the gateway for the wireless which means the wireless can't talk unless the wired is plugged in.

Set the wired ethernet back up to the default static IP of 192.168.200.1, no gateway, no dns. This information should actually be in the first post.
 
Last edited:
I had this same thing happen to me. i ended up having to go to the advanced tab of the LAN and uncheck the auto start option and reboot the device. I'll see if i can get some screen shots when i get home.
 

Jason J

TVWBB Fan
You can't have both adapters on the same subnet. Even worse, DHCP sets the wired ethernet as the gateway for the wireless which means the wireless can't talk unless the wired is plugged in.

Set the wired ethernet back up to the default static IP of 192.168.200.1, no gateway, no dns. This information should actually be in the first post.


Thanks sir. I actually unchecked load at boot and it now works just fine. Everything is now working fine.

Is there some place we can buy you a "beer" or donate as a thank you for all your hard work?
 

BrianGudas

New member
Hi Guys,

I have found all this really helpful as I finish my build. I am having a little trouble with the Wifi, please excuse the very basic questions and if there is a more appropriate place for these please let me know and I will move there instead. Directly related to this string

1) I have just completed my board build (HM v4.0)
2) I have mounted to a rPi Model A
3) The model A does not have an Ethernet port

How do I configure the WiFi without being able to wire directly per the instructions above.

Second question, "Step 2: From a computer on your network change your IPv4 address to 192.168.200.2..." Am I changing the address of my mac short term or an I hardcoding the rPi to that address. I assume the latter but would appreciate the confirmation

Thanks for the help
Regards
Brian Gudas
 

Bryan Mayland

TVWBB Hall of Fame
The easiest way to configure wifi on the A is to plug a keyboard into the USB port and a monitor into HDMI. Wait for it to boot up and say "Press enter to activate this console" (easy to miss in all the messages scrolling by). Press enter, type `wifi-client yournetworkname yourpassword`. Wait about 60 seconds to make sure the pi has fully booted (if this is the first time) then pull the power, insert the wifi dongle, and power it up. If you got the edimax you should see the blue light in it blinking in about 20 seconds and it will have an address in 30-45.
 

T. Stinnett

New member
I finally got around to finishing my Model A and HM 4.0 and everything looks good so far, rPi and HM booting fine. My network is not currently encrypted and I am entering 'wifi-client myssid' and rebooting and am getting nothing from the adapter on reboot. No blinking, not much of anything. Any ideas? I do see on boot that it appears to recognize the adapter and I do see some cfg80211 lines with the final stating "indicate_disconnect".

I've meddled with Openwrt in the past but never from the command line, push comes to shove I'll attempt to edit the config files. As I recall they should live in etc/wireless.... but it's been a while.
 

Bryan Mayland

TVWBB Hall of Fame
Yeah if you don't specify an encryption, it defaults to WPA2. To get no encryption you have to pass none (for both the encrypting and password I believe:
wifi-client yourssid none none
 

T. Stinnett

New member
Working great..... for a network that is not encrypted "wifi-client yourssid none none" brought the interface right up. This may be a good addition to the Wiki. Thanks for your help Bryan!
 

Bryan G.

New member
I'm hoping someone can help me out on this final step of getting my HM working. It appears everything is working except wifi. I've followed the wiki and can access the HM over LANj on 192.168.200.1 and can find my wireless network. After going through the steps and going back to the Interfaces tab, I can see the network I just added but it does not have an IP addressed assigned to it. It just says:
MAC-Address: 00:00:00:00:00:00
RX: 0.00 B (0 Pkts.)
TX: 0.00 B (0 Pkts.)

Anyone know what's going on?

fy1s7l.jpg
 

Bryan G.

New member
I also noticed that when I power cycle it I lose the wifi settings I just added.....but other settings such as those for the probes are not lost.
 

Phillip P

TVWBB Fan
I also noticed that when I power cycle it I lose the wifi settings I just added.....but other settings such as those for the probes are not lost.

I think that is because the probe settings are stored in the heatermeter board, not the RPi.

It is weird that you wireless connection hasn't given you your IP address and shows no TX/RX.

Do you have a DHCP server on your network?

In the WiFi tab, are you connecting as a client?
 

Bryan G.

New member
DHCP is handed by the router I'm connecting to. I'm setting it up as a client (I'm not sure it's actually connecting though.)

When hard wired, DHCP assigns it an IP of 10.0.0.x and I'm still able to access it through 192.168.100.1. Is supposed to show both the 192 and the DHCP IP addresses for the connection (see pic in first post)?

I'm seeing this on the LAN connection:
Uptime: 0h 4m 41s
MAC-Address: B8:27:EB:2F:FC:34
RX: 135.28 KB (1264 Pkts.)
TX: 561.52 KB (973 Pkts.)
IPv4: 192.168.200.1/24, 10.0.0.5/24


Also, why do a have a "fallback" lan connection that appears to be identical to the regular LAN?
 

Phillip P

TVWBB Fan
DHCP is handed by the router I'm connecting to. I'm setting it up as a client (I'm not sure it's actually connecting though.)

When hard wired, DHCP assigns it an IP of 10.0.0.x and I'm still able to access it through 192.168.100.1. Is supposed to show both the 192 and the DHCP IP addresses for the connection (see pic in first post)?

I'm seeing this on the LAN connection:



Also, why do a have a "fallback" lan connection that appears to be identical to the regular LAN?

Bryan will have to definitively answer the fallback question for sure but I believe the 192.168.200.1 fallback is the default config setting hard coded in the install that allows you to reach the HM via TCP/IP if you screw something else up. (an alias for your wired network adapter)

Is the wired connection going to your router or directly to your computer? What wireless adapter are you using?

Double check that under Network->Interfaces that your protocol is set to DHCP Client.

Can you SSH into the box via wired connection? If so, run "ifconfig" and "netstat -all" and post the results.
 
Last edited:

Bryan G.

New member
I'm using this EW-7811un wifi adapter: http://www.amazon.com/exec/obidos/ASIN/B003MTTJOY/tvwb-20

^which I believe is the exact one mentioned in the FAQ. When it's hardwired, I'm going in to the router and after changing the ipv4 settings on my laptop I can find it on 192.168.200.1. I do notice that when I plug it in to the router it gives me a message on the lcd that it has a DHCP IP from the router (usually 10.0.0.5). Should it show that or the 192.168.200.1 IP on the LCD screen?

It is definitely set to DHCP.

This is my first PI project and I'm way rusty on ssh. I'd need a little tutorial on how to do that. Can I do it while it's hardwired in to the router or do I need to have another cable and plug it right in to a computer?


I guess as a fallback I could try to dig up a keyboard and use the HDMI output to try to manually set it up....but I'm trying to avoid that as I don't think I have a compatible keyboard handy.
 

RalphTrimble

TVWBB Diamond Member
I think the network should be easier to setup through the HM interface than SSH anyway....

Are you sure your router isn't blocking the connection somehow with security?

I haven't mentioned this before, but with this newest release of the HM software I find my HM does NOT connect to my wifi the first time I power it up. I seem to have to let it boot then power cycle the HM, the second time around it always connects. IDK WHY, this is new behavior for my HM with this software version, never happened before... So maybe try letting it boot, then power cycle the HM and see if it connects to the wifi. Also, try disconnecting the LAN cable and boot and see if the wifi connects, watch the HM screen for the IP.
 

Bryan G.

New member
It's deffinitely a PI issue....the router isn't blocking it. I've tried two APs now and bother give the same result. I've tried waiting, power cycling, etc. I think the root of the problem is that the PI is not saving the wireless configuration so when the power is cycled, everything is lost.

I just confirmed that the wireless is working upon initial setup. I can see the wifi device connected in the router's clients table as 10.0.0.7 (wired is 10.0.0.5) and I can even access it over the wifi IP but as soon as I pull the power and start it back up, it disappears.

What could be wrong in the PI that would keep it from saving these changes?
 

 

Top