Few issues....

MartinB

TVWBB Super Fan
Got new HM up and running.
4.3 and pi zero W.

Wont connect to my home network yet from config.txt or downloaded image.

Connect to HM via wifi, i can set up network connection via interface and it does vonnect to home router .Then wifi for HM dissapears...cant connect with another device.

Now, wanting to go back to direct phone wifi connection, i disabled that network connection with home router....this seem to disable all the wireless of the pi...had to put re-imaged card in pi to be able to talk to it again .

Should i have "removed" that network to disable it? Its nice to always know same address if connect direct at home and switch to it if needed. Yeah i know about ddns, havent got to that yet.
 
Last edited:

RalphTrimble

TVWBB Diamond Member
Well, sounds like you had it working but didnt know it perhaps? If you started from an Access Point build and used a wireless device to scan for available networks and connected to HEATERMETER, then loaded the HM web gui and went to config/network/wifi and scanned for and connected to your wireless network, when you apply that change your HM changes from AP mode to Client mode and you will no longer see the HEATERMETER access point if you scan with a wifi device. At this point you are connected to your wireless network and need to connect to whatever IP is assigned to your HM by the router (from any device connected to the same network). When the HM boots it should show the IP address on the LCD, or you can go to http://heatermeter.com/devices/ to see if your device is listed there.
 

MartinB

TVWBB Super Fan
Well, sounds like you had it working but didnt know it perhaps? If you started from an Access Point build and used a wireless device to scan for available networks and connected to HEATERMETER, then loaded the HM web gui and went to config/network/wifi and scanned for and connected to your wireless network, when you apply that change your HM changes from AP mode to Client mode and you will no longer see the HEATERMETER access point if you scan with a wifi device. At this point you are connected to your wireless network and need to connect to whatever IP is assigned to your HM by the router (from any device connected to the same network). When the HM boots it should show the IP address on the LCD, or you can go to http://heatermeter.com/devices/ to see if your device is listed there.

Yes.
My question is...if i dont want to connect to that network anymore...maybe it not at home, or router issues, etc. I "disabled" it, and then HM didnt talk to anything. No ip address on startup, no AP. To reset that configuration without wireless required new image, unless plugged into pi with cable maybe. So will " removing" the network put it back in AP? Because disabling seem to render it unable to communicate anymore via wireless.
 
Last edited:

RalphTrimble

TVWBB Diamond Member
I suggest you try RESET from the HM LCD menu, see if that puts it back into AP mode. If not I would dl the image from heatermeter.com/dl that matches your needs and write that to your SD card and start out fresh.., and dont delete your network devices.
 

Bryan Mayland

TVWBB Honor Circle
I would not ever disable or delete the wifi interface from the webui, as there will be no way to re-enable it on a Pi Zero W without reimaging the SD card or using the "Reset Config?" from the HeaterMeter device LCD menu. Reset Config resets all config of the HeaterMeter itself as well as the Pi's configuration if it is up and running at the time. This will reset it back to being an access point you can connect to called "heatermeter" (not to being a wifi client).

If you disable or remove the wifi network in the webui, it will NOT go back to being an access point, it will just not have a network anymore after that.
 

MartinB

TVWBB Super Fan
I would not ever disable or delete the wifi interface from the webui, as there will be no way to re-enable it on a Pi Zero W without reimaging the SD card or using the "Reset Config?" from the HeaterMeter device LCD menu. Reset Config resets all config of the HeaterMeter itself as well as the Pi's configuration if it is up and running at the time. This will reset it back to being an access point you can connect to called "heatermeter" (not to being a wifi client).

If you disable or remove the wifi network in the webui, it will NOT go back to being an access point, it will just not have a network anymore after that.
Well, not the wifi interface, but thats possible too. It seems, just network you joined. But same thing, it gets stuck without wifi communication.

So reset config is the way to change back to AP. But you lose probe and tuning settings? And wifi network/password too . Would be a bit of hassle to reconfig all in middle of a cook. ( Yeah, it would take about 1 min). Can the baseline image be modified to your normal parameters ? I saw some backup options, not sure what they do.
 
Last edited:

RalphTrimble

TVWBB Diamond Member
I've been asking for a way to stash configurations from the HM GUI and load them from the HM LCD menu for a long time, so you can save various wifi configs, or configs for different pits etc, and load them easily from the HM hardware. Brian always says basically there is a lot more too it than meets the eye so it has never happened. To my (non programmers) brain it sounds so simple...

Have a button on the HM Config page to "save config" and choose number (perhaps 1-9) that will stash a config file with that number on the SD Card. Add menu to HM LCD for "load config" and allow you to select 1-9, push button, done. Apparently not as simple as I would like it to be. Other methods have been discussed here that work to save/load configs using the web etc, but nothing as simple as the above or that can be done from the HM hardware when you do not have a network connection... and that's when you really need it, right?!

If you DL the client mode image with your wifi credentials from the HM website and update the HM via its web gui you will not lose all your other settings, so that is one way to change config, but you need a network connection to do that, or need to image the SD card. Maybe you could stash those configs on the SD card and then load them from the HM config menu, but once again without a network connection you can't get to the HM config GUI to do that.

Another method is to have multiple wifi adapters and config each one for a different network or mode. Then boot with the network adapter for the network you are looking to connect to. Less than ideal but is probably the easiest way to change networks.

You've hit on a long standing humbug with the HM which I wish would be overcome, it's one of the few features I have been looking for that haven't materialized over the years I have been happily using the HM.
 
Last edited:

Bryan Mayland

TVWBB Honor Circle
If you DL the client mode image with your wifi credentials from the HM website and update the HM via its web gui you will not lose all your other settings, so that is one way to change config, but you need a network connection to do that, or need to image the SD card.
Just to clarify this point, if you do a "reset config" you always lose all configuration when the Pi is reset, it will not go back to client mode regardless of the image initially used. The "preconfigured" image only works the first time it boots, to prevent from resetting the wifi configuration on every boot.

I'm not sure how much network reconfiguration you'll be doing on a regular basis, but if you are, I'd recommend going to a Pi 3B+ which has its USB ports exposed through the case. Then you can just put the wifi config you want on a USB stick and when it boots, it will pull the wifi configuration from the USB stick. That makes things a little easier than opening up the case to reflash the SD card every time you want to make changes. If you're only doing a one time setup, or once every blue moon, then you can use the LinkMeter -> Wifi webui to quickly change to AP mode or to client mode.
 

MartinB

TVWBB Super Fan
So
Played around with connecting to router again

I can connect, get address
But cant talk to heatermeter thru it

Hm works fine as access point.

When i type in address, 192.168.1.209, get error message
And heatermeter page shows following





Tried reset, new images, always same.

Hm also doesnt appear on routers device. List......even though it seems to have assigned an address.

Is it possible that even though nothing shows for the network with my router yet when AP connected, none exists, once i create it it automatically disables still??? Because i disabled it once? Somhow that config doent reset?

When i hotspot my phone....i can connect the HM to it and connect to it thru the assigned address. 192.168.43.209..
 
Last edited:

RalphTrimble

TVWBB Diamond Member
Is it possible that even though nothing shows for the network with my router yet when AP connected, none exists, once i create it it automatically disables still??? Because i disabled it once? Somhow that config doent reset?

When i hotspot my phone....i can connect the HM to it and connect to it thru the assigned address. 192.168.43.209..
I have a hard time following what you are trying to say, or ask here? (above)

From the parts I do understand it sounds like your HM connected to your router at some point but is not currently connected. That would explain not showing up in the routers device list. I would suggest you momentarily drop security on your router then reboot the HM, see if it connects, look on the HM LCD for an IP to show. If it shows use a computer on your network to connect to that IP with a browser. If you get connected then enable security on your router and see if it still works.

On the HM AP mode and Client mode are two different things, you're running one or the other. In AP mode the HM functions autonomously as its own hotspot, works pretty easily because it doesn't have to interact with other devices, when it does it is in control assigning IP's etc. In Client mode your network is in control, the HM tries to connect to the network using the settings and credentials you have entered in the HM but your router has to allow access and assign IP's etc, so client mode can be more complicated.

I suggest you put your HM in AP mode, connect with your phone and go to network/wifi section. Temporarily turn off security on your router and then SCAN for WIFI networks with your HM, pick your network and try to connect. If that seems to go well you can try the HM devices page to get the IP or watch the LCD for the IP. Use browser from computer on the same network (not the phone that was connected to AP mode) to connect to HM. If it works re-secure your WIFI and cross fingers it keeps working. If it drops then you have an issue with the firewall.
 

MartinB

TVWBB Super Fan
I have a hard time following what you are trying to say, or ask here? (above)

From the parts I do understand it sounds like your HM connected to your router at some point but is not currently connected. That would explain not showing up in the routers device list. I would suggest you momentarily drop security on your router then reboot the HM, see if it connects, look on the HM LCD for an IP to show. If it shows use a computer on your network to connect to that IP with a browser. If you get connected then enable security on your router and see if it still works.

On the HM AP mode and Client mode are two different things, you're running one or the other. In AP mode the HM functions autonomously as its own hotspot, works pretty easily because it doesn't have to interact with other devices, when it does it is in control assigning IP's etc. In Client mode your network is in control, the HM tries to connect to the network using the settings and credentials you have entered in the HM but your router has to allow access and assign IP's etc, so client mode can be more complicated.

I suggest you put your HM in AP mode, connect with your phone and go to network/wifi section. Temporarily turn off security on your router and then SCAN for WIFI networks with your HM, pick your network and try to connect. If that seems to go well you can try the HM devices page to get the IP or watch the LCD for the IP. Use browser from computer on the same network (not the phone that was connected to AP mode) to connect to HM. If it works re-secure your WIFI and cross fingers it keeps working. If it drops then you have an issue with the firewall.

It connects to router, gets ip adresss, shows on hm, showed on hm devices page with error. Also finally shows on router connected connected devices (why 30 min?), But receive unnavailble message when try to go to address.

Hotspotting my phone makes it a router. The assigned ip shows on hm screen. Have to input ssid and pass like any router to connect to it. No problem going to the ip address my phone assigns.

It connected to home router before i disabled that network in the interface thinking that might switch back to AP. Hasnt been able to access via it since, even though has been reset, it does assign the ip when connecting though.

I can try without security maybe, not sure att allows that


What my router shows: no wireless from HM.(lede)
 
Last edited:

RalphTrimble

TVWBB Diamond Member
I am still confused. In general for the HM AP mode refers to having the HM be in AP mode, having the HM function as the hot spot. You are referring to making your phone the hotspot?... and if I read you correctly you are saying your HM will connect to your phones hotspot and it works?... but wont connect to your router and work...???
So first bit of confusion, if your phone is set as a hotspot what do you have connected to your HM to make it scan for and connect to your phones hotspot? When you SCAN on the HM wifi radio does it show your wifi router, and if you select does it appear to connect?
Funny you say ATT, 'cause I had a HM refuse to connect to my ATT wifi once, I dropped wifi security and it connected, then turned security back on and it still connected... had been beating my head up against the issue for hours prior to deciding to turn of the wifi security to test. That is why I made the suggestion....
 
Last edited:

MartinB

TVWBB Super Fan
I am still confused. In general for the HM AP mode refers to having the HM be in AP mode, having the HM function as the hot spot. You are referring to making your phone the hotspot?... and if I read you correctly you are saying your HM will connect to your phones hotspot and it works?... but wont connect to your router and work...???
So first bit of confusion, if your phone is set as a hotspot what do you have connected to your HM to make it scan for and connect to your phones hotspot? When you SCAN on the HM wifi radio does it show your wifi router, and if you select does it appear to connect?
Funny you say ATT, 'cause I had a HM refuse to connect to my ATT wifi once, I dropped wifi security and it connected, then turned security back on and it still connected... had been beating my head up against the issue for hours prior to deciding to turn of the wifi security to test. That is why I made the suggestion....
Crossing fingers
Restarting my home router and now it seems to work.:)
Usually thats first thing i do....

But yes...it connected to router, got ip, and wouldnt communicate . A phone is a router in wifi hotspot mode. Enter the ssid and pass on hm wifi page and it connects to that as a client, just like any router, and can access internet via cellular. It did this no problem.


Now to port it
 
Last edited:

RalphTrimble

TVWBB Diamond Member
I figured it was an issue with the router rather than the HM.... specially after you said ATT... lol
Glad you got it working.
 

MartinB

TVWBB Super Fan
I figured it was an issue with the router rather than the HM.... specially after you said ATT... lol
Glad you got it working.
Not the end of it.
Trying to activate ddns
Updated software list but luci - a p p - ddns wasn't in list
So filled in the blank to find install it
Which it did

Got an error on installation
Get an error when try to remove
There is no services tab
So re set configuration on heater meter
And now the router recognizes it as quote " off"
Still trying to reboot router again.....

 
Last edited:

MartinB

TVWBB Super Fan
So

Ported to 8080

Can connect from internet.....hooray, via router ip and port

But...cannot connect directly via address assigned by router. Its there, it shows on router devices, cannot talk directly to it again. Dont feel like restarting router again to see. Is this normal? Or is ATT router just crap?


Tried no ip.......sucks. dont work.
Tried dyndnss...... Goes to page...see luci text be at top corner....then sad face and says unnavailable. Sucks too.

What up with this? Direct connect works fine. (Via cell or vpn doesnt work here neither,)

Att uverse router apparently doesnt support ddns. But address doesnt change often if ever i understand. Still be nice if the luci-app-ddns worked.

Also....really cant connect to heatermeter on internal network via outside address, from inside the network. Something about packets writing across port i read...Hmmm...99% of time thats exactly what must be done..from home. Using vpn is a workaround.. lightning fast by comparison.but is there another easier way?
 
Last edited:

Bryan Mayland

TVWBB Honor Circle
You're never going to get that luci-app-ddns to work if it requires shellquote(), which wasn't around in the luci core we're using. You have to reset your heatermeter back to default to get any of the webui working again (or ssh in and uninstall that package). You can just manually set your outside IP address in no-ip or dyndns though, and if it doesn't ever change you're good to go indefinitely.

And yes, many routers do not support accessing internal port-forwarded devices by the external IP address or need some special setting to make that work.
 

Steve_M

TVWBB Guru
I used to use a simple curl one-liner to update no-ip before switching to duckdns ( also updates via curl )

You could add this as part of your heatermeter boot sequence or even as a scheduled cron job.

Doing DDNS updates is yet another task I leave to my 24x7 running RasPi I have in the basement. To me, unless you're travelling with the HM, it doesn't make sense to task it with doing DDNS updates.
 

MartinB

TVWBB Super Fan
You're never going to get that luci-app-ddns to work if it requires shellquote(), which wasn't around in the luci core we're using. You have to reset your heatermeter back to default to get any of the webui working again (or ssh in and uninstall that package). You can just manually set your outside IP address in no-ip or dyndns though, and if it doesn't ever change you're good to go indefinitely.

And yes, many routers do not support accessing internal port-forwarded devices by the external IP address or need some special setting to make that work.
Couldnt find any special setting to access the forwarded port by external address in my router. But connecting via vpn isnt bad. Just slows internet a tad . At least conecting via router lets have internet access while monitoring cook. I was using two devices.

I take it i should still be able to connect direct on my assigned internal ip when port forwarded, and not being able is an artifact of my router? I let router assign the ip then made it fixed so id always have same bookmark.....but not been able to connect directly anymore. I can try restart again..


Yeah, if my external ip is constant...no need for ddns service. Just a bookmark. But i set up two with the address....neither worked....even trying over cell or vpn.
 
Last edited:

MartinB

TVWBB Super Fan
Couldnt find any special setting to access the forwarded port by external address in my router. But connecting via vpn isnt bad. Just slows internet a tad . At least conecting via router lets have internet access while monitoring cook. I was using two devices.

I take it i should still be able to connect direct on my assigned internal ip when port forwarded, and not being able is an artifact of my router? I let router assign the ip then made it fixed so id always have same bookmark.....but not been able to connect directly anymore. I can try restart again..


Yeah, if my external ip is constant...no need for ddns service. Just a bookmark. But i set up two with the address....neither worked....even trying over cell or vpn.


So I reconfigured the heater meter in order to get rid of the faulty Lucy - A P P - ddns.

On restarting it connected to the router and..... You can access it from the router by typing the IP address. I had to go in and forward the port 8080 again. Could still access it from the router by typing the IP address. But could not access it over the Internet through the port. Until re booted the heater meter by turning off the power and turning it back on.

After that you can access it over the internet, but not via directly from the router.

So it does not appear that my router allows you to access a device directly if it is ported to 8080. Probably could when it was ported to 80 , but att isnt compatible with that, but the 8080 even after changing , really didn't take place until it was restarted?
 
Last edited:

Top