Wifi - no mac address, scan doesn't find any networks


Mike Wallace

TVWBB Member
Just finished my build. On the network-interfaces tab, the wireless adapter shows a mac address of 00:00:00:00:00:00. On the wifi tab, pressing scan doesn't bring up any wireless networks.

I bought the 'Generic "niceEshop" 150Mbps with antenna' adapter, which should have the RT5370 chip. However, to test it I plugged it into my windows machine, and had to use the CD to install the driver. The CD has rtl8192cu drivers, and once installed it worked on my windows machine.

I even tried a 1.5A power brick instead of the 1.0A I bought, no change.

Any ideas? Do I need to buy another adapter?

This is the one I bought:
I've gone ahead and ordered the Edimax 150 Mbps one.

Maybe I'm misreading the wiki for supported wifi adapters, the one I bought is tested & recommended for linkmeter v11, and recommended when wanting to run as wifi AP mode. I assumed that meant it would work for both modes? Not just AP mode?
I am running a different WiFi adapter that's based on the RT5370 chipset and it does work in AP mode and Client mode...
Once I flashed the software to the SD card, put the card in the pi, and turned it on.. without changing anything I should have just been able to go to the web interface, click on network, wifi and click on scan? Or do I have to actually change the adapter from AP mode to client mode? I tried that too, and the mac address still shows 00:00:00:00:00:00 even after several reboots and leaving it running for a while.
Well, my experience with the RT5370 adaptor went like this. I had the Edimax connected to my WiFI, I powered down the HM, connected the RT5370 and powered up, expecting that I would have to use a LAN cable to connect and configure the new WiFi adaptor. Much to my surprise when it booted the RT5370 connected to my WiFi through the setup from the Edimax. You do have to manually change it to AP mode if you want that, though that was after I already setup the client connection, I think on a fresh install the WiFi comes up in AP mode by default on the latest release.
Right, and I don't want it to run in AP mode. I want it to connect to my home network. When I click scan, absolutely no networks come up. When I used the dongle on my pc, 7 or so networks came up (mine and many neighbors)

Under wifi page, do I set the mode to client? Do I put my home wireless network name in ESSID or BSSID?

I'm still wondering why there is no mac address showing when on the interfaces tab, or it's all 00s. Thinking it means the dongle isn't supported.
I haven't done a ton of messing with AP mode, but I would say first set the device to Client mode, save and reboot the HM. Then go back to NETWORK - WIFI and see if you can Scan now.... When in AP mode the HM is essentially functioning as a router, a device that other devices connect TO, complete with its own DHCP Server.... So I don't think you can scan while in AP mode. (not sure on that, but would make sense) When I setup a connection to my WiFi I have always used the SCAN function, and I have also seen MAC address of all 00's on my devices at times, so that is not a death notice for your adapter....
Ok i'll keep trying. I've been at this for hours last night and again tonight trying to get it to work. I should just be able to click scan and have it come up.
Yeah, it sounds like your wifi adapter is not playing nice with OpenWRT. Hopefully the new one will.
It was the adapter. The 'niceEshop(TM) Mini 150mbps USB Wifi Wireless LAN Card 802.11 N/G/B Adapter With Antenna' doesn't seem to work.
Edimax is OK, it works reliably in client mode, but doesn't work in Access Point mode. The RT5370 seems to work better with the rPi since it will work in client mode or AP mode...
And the original one I ordered 'NiceEshop(TM) Mini' was listed in the wiki as RT5370, and advertised online as RT5370, and it didn't work AT ALL. Neither mode.
I don't know what to tell you about that, whether its not really a RT5370 based adapter, or if they are doing something strange to make it not compatible, or maybe you got a bum adapter, or are doing something wrong.... All I can say is Bryan experimented with the RT5370 based adapter and it worked well and so have I.