Pit temp won't change - always says 55F

RKHanso

TVWBB Fan
I searched this forum and Google and didn't find an answer or anything related to the problem I'm seeing today.

I have a 4.2v of Heatermeter that has been working great the past few years. I'm using it for the first time this year today, and when powering it up, it says "No Pit Probe" like it should.
When I plug a pit probe in (thermocouple/yellow connector), it shows 55F. It's currently 13F outside. I started heating up the grill and the temp doesn't change on the Heatermeter.
I tried another similar pit probe and it does the same thing, only displaying 55F. I checked the web interface and it is at 55.7F. Not changing.
The Maverick temp probes work OK and read the correct temperature.

Is this fixable? I'm not sure how to go about even searching for a fix on this.

Thanks.
 

RKHanso

TVWBB Fan
Well, I should have tried this first.
I brought the Heatermeter in from the cold outside, removed the innards from the case and it's working OK with both pit probes now.
I must have something pinched or maybe a cold solder joint that showed up a few years after making it. Odd though, I've used this same Heatermeter in the winter often with no other trouble.
I'll put it back together and see if it still has trouble.
 

RKHanso

TVWBB Fan
Well, the pit probe is reading the correct temp and working OK.
But now the meat probes (Maverick ET-732) are acting goofy.

I have 2 meat probes connected. In the web interface, they are both alternating between OFF and 5.6F -- but it's really about 14F outside now.

What in the world is happening to this thing?
 
Last edited:

RKHanso

TVWBB Fan
Odd -- unplugging them and plugging them back in got them working again.

I think I have a case of the gremlins.
 

Bryan Mayland

TVWBB Honor Circle
Yeah that's definitely some weirdness going on there. I'd say it was maybe some corrosion on the contacts in the probe jacks but that wouldn't explain why the pit probe would be all wonky too. You could maybe check the 3.3V power when you're seeing weird numbers, it should be a very stable value within 1-2% of 3.300V.
 

RKHanso

TVWBB Fan
I do have a bit of a troublesome power connection from the wall-wart. I did re-solder the 3 pins on the jack on the HM board, but when I wiggle the power plug the wrong way, the HM does lose power. Wiggling it makes the light come off/on quickly. It's not the solder joints on the jack. It must be the jack itself or the plug from the wall-wart. It's been doing this for a year though. And the oddity with the temp just started today.
 

Top