New Android app: PitDroid

Karl Vacek

TVWBB Member
Galaxy S7, Android 7.0, July security patches.
If I uncheck all alarms I can close it with the "Back" button on the phone and it's really closed. If anything's checked it just persists in the background till I restart the phone of close the application in Settings. I don't see a close button anywhere. I guess it's not a tragedy, just a pain. Thank you!
 
Ok, I got my HeaterMeter working again and flashed the snapshot and it looks like the auth is working again, thanks Bryan. And Jesse, guy who gave me a 1 star review on the Play Store for the auth not working, it's time to update that review!

Hi Colin (and perhaps others that can answer my question :) ),

I'm a member of a Dutch BBQ forum, got myself a HM last week to use with my UDS. One of the first things I did was download PitDroid. Sadly I got the authentication failed message as well, quickly found this thread saying it should be solved. Any idea what I might be missing, as i'm still getting the message with the latest version from Play Store?

Thanks,
Melvin
 

Colin Bonstead

TVWBB Member
Hey Melvin, I'm actually doing a smoke right now and it authenticated fine and I'm able to change the pit temp. I haven't updated my HM firmware since last time though, so I suppose it's possible something has changed again. Are you able to at least see the temps, even when you aren't able to authenticate?
 
Yeah, reading the temps works. Alarms ... sort of work .. not quite sure there yet. Changing the setpoint doesn't work though.
Another member of a Dutch forum i'm on also has the same problem with the app, he's got the same HM as I have. Could it have something to do with the version we have?

Firmware Version is LEDE Reboot SNAPSHOT r3799-1300671 / LuCI Master (git-17.078.53745-180f2d6). Kernel Version 4.9.14. Android Version i'm using is 7.0, will try later with an old tablet that should be on an earlier Android version (battery's dead at the moment).

Ports should be forwarded correctly, I can logon to the web UI on my phone.
 

Colin Bonstead

TVWBB Member
Ok, it looks like I'm on a little newer version than you (git-17.100.70571-29fabe263), if I go to the heatermeter devices page mine says HeaterMeter 20170916B. I tried updating to the new stable version that was released recently, but my crappy Edimax wifi adapter didn't seem to work with that, so I rolled back for now. It's strange that you can login fine from the web ui but not the app. It might be worth updating to the new stable version of HM if you can.
 

Steve_M

TVWBB Guru
The stable version is:
Code:
LEDE Reboot SNAPSHOT r4558-438dcbfe74 / LuCI lede-17.01 branch (git-17.100.70571-29fabe263)
 
You guys are the best! I flashed to LEDE Reboot SNAPSHOT r4558-438dcbfe74 / LuCI lede-17.01 branch (git-17.100.70571-29fabe263). Now PitDroid works perfectly. Authentication Succeeded, and just changed the setpoint. Thanks a bunch! :D
 

Colin Bonstead

TVWBB Member
Hey guys, sorry about the crappy state of the app the last few weeks. Google forced me to update it to the latest API, and there were a lot of changes to deal with and it did not go well. I just pushed a new version that hopefully fixes all the major issues. I've got some more polish I'd like to do, but this will hopefully at least get it in a functional state for everyone again. If it's a total fail again let me know and I'll try to get it resolved.
 

JKalchik

TVWBB All-Star
Colin, I'll be firing up my HM on Thursday. I'll make sure to report back with results (Droid Turbo. Yes, I'm old.)

It worked fine for me a week ago.
 

Tim Loftus

New member
It has been working great for me, as of last night and this morning! Samsung S7. woohoo for overnight cooks. I do have to admit I cringed a little bit when I saw it was updated. It worked so well and I don't like change!1 that is on me though. thank you so much for this app! it has been a life saver.
 

Jerry Allen

New member
Setting temp does not work in LEDE Reboot SNAPSHOT r5264-94491a1571 / LuCI Master (git-17.293.52428-5e28002)
The API key is not set by PitDroid and there is no place to set it in PitDroid.....

Will this be updated at some point?

Jerry

Edit: it appears the API write is just broken by comments on github........

Great app anyway at least we can read the data.
 
Last edited:

Jason Abendroth

New member
Has anyone experienced PitDroid crashing the heatermeter remote monitoring?

I was running mine for a good while just monitoring via my brower. But once I opened and logged in via PitDroid, it crashed something and the only was to reconnect with the browser or put drops was to unplug the heater meter.
 

RalphTrimble

TVWBB Diamond Member
I lost track of pit droid when it changed to a format that limited the setpoint to 350F unfortunately. I do a lot of higher heat cooking as well as low and slow, but pit droid doesn't play nice with temps above 350. Wish it would....

I just popped it up and it doesn't seem to have connected, ip is correct. IDK if this is the latest release or not, will check up on that...

I have gotten used to working with the regular HM gui on my smartphone, works out pretty good, but I do have a large phone/screen. Which makes me think, once upon a time I had a crappy phone and recall there was a "light" HM gui for "clever" phones, wonder if that still exists? (Bryan?)

EDIT: Just uninstalled and reinstalled, does not connect. IP and open ports verified. I am signed up as a BETA tester if that matters.
 
Last edited:

Jason Abendroth

New member
I lost track of pit droid when it changed to a format that limited the setpoint to 350F unfortunately. I do a lot of higher heat cooking as well as low and slow, but pit droid doesn't play nice with temps above 350. Wish it would....

I just popped it up and it doesn't seem to have connected, ip is correct. IDK if this is the latest release or not, will check up on that...

I have gotten used to working with the regular HM gui on my smartphone, works out pretty good, but I do have a large phone/screen. Which makes me think, once upon a time I had a crappy phone and recall there was a "light" HM gui for "clever" phones, wonder if that still exists? (Bryan?)

EDIT: Just uninstalled and reinstalled, does not connect. IP and open ports verified. I am signed up as a BETA tester if that matters.

yep. For me to get it to connect i have to clear the cache and data then re input my ip address, and it only stays connected for a bit before it crashes the HM. What browser are you using for the HM UI?
 

MartinB

TVWBB Pro
Havent actually used it, but played with it and it seems to work. Doesnt always set the set point which is a little frustrating. And then alarm function seemed to kind of lock it up one time. To clear that just restarted app.

Seems simple, clean, functional.
 
Last edited:

Colin Bonstead

TVWBB Member
I don't have access to my smoker right now, so I haven't really been using my Heatermeter. That said, I'm not sure how PitDroid could crash the Heatermeter, I'm just using the normal API calls. Maybe there's some kind of bug that's causing it to access it too frequently? I can take a look.

And Ralph, if you want a peak temp higher than 350 just change it in the settings.
 

RalphTrimble

TVWBB Diamond Member
Thanks for the tip on the min/max settings, however, I have changed the max setting but the scale did not change on the dial? I still can't get it to connect even though I can connect to the HM via web browser from the same device? Last update shows no data, temps do not display on the dial, changing the setpoint with the app has no effect on the HM.
I am happy using the web interface on my smartphone, don't really need the app, but I figured I would report the issues I am seeing in case there is a problem with the app that needs to be addressed.
 

Top