help! I finished the soldering. HM won't boot. Im at a loss at how to troubleshoot

Dusty Hicks

New member
Hi, Its my first time using a HM. I got the 4.3 - four-thermistor kit and I'm using a 3B+ RPi to run it. I finished all the soldering last night, which i thought went well. I mounted the image onto my MicroSD card from the site, i put the SD card into the rasberry pi and tried to boot it up. Nothing happens. There is only a single row of dark cells (i can adjust their darkness with the contrast controller, but i'm confused why only one row lights up, i'm wondering if that is indicative of a soldering issue or something). Also, when i plug my Raspberry pi into my TV and watch it when i try to boot it up, it only shows a sort of rainbow pixel screen and that is it. Lastly, the RPi only shows a beeping red light when i try (and fail) to boot it up, I'm not sure if that is helpful information or not.

I tried going to the troubleshooting page, but honestly I don't even know how to follow those instructions. The first on that list:
-Start by ensuring you can connect to openwrt on your Raspberry Pi see [HeaterMeter 4.x Software](HeaterMeter 4.x Software#configuration).

1. I have no idea how to connect to openwrt on my Raspberry Pi, and i wasn't able to figure it out using Google. I've done raspberry pi projects in the past so im loosely familar with the software side but I'm by no means and expert. Am i supposed to install Raspian on this first to somehow troubleshoot the issues, or to access Openwrt?

2. I do not know how to tell the difference between a hardware issue and a software issue. I don't know if it isn't booting because i soldering something wrong, or because I did something wrong on the software side and i was hoping someone could help me figure it out. I really feel like I did a great job on the soldering, I'm really good with my hands (I do dentistry every day and I have to do things on a small scale all the time). I made sure every solder joint flowed through to the other side and I was super careful about polarity with the components that mattered.

Lastly, as a separate question, from the assembly video, i got the impression that when i solder in the four thermistor jacks, i only need the five 10K resistors (four next to the jacks and one other 10K resistor on the side) and i don't need to use the 100K resistor at all, but i thought I read somewhere on here that on the pit probe (thermistor version), you need to install BOTH the 10K and 100K resistors right next to each other. Does this seem right? It seemed from the assembly video that you are supposed to leave the 100K resistor out altogether, at least right next to the thermistor jack.

Thank you for the help!


TVWBB Diamond Member
In reverse order....

For 4 thermistor probes you should install all four 100K resistors and all four 10K resistors for the probes.

On your boot (or lack there of) the black blocks are what you see when the ATMega on your HM has not been programmed, indicating either the software is not loading properly on the rPi (software issue) or the rPi is not communicating with the ATMega (hardware issue). Since you connected to a monitor and do not see the scroll of text that should happen when the HM software loads I would suggest you have a software problem.

Did you choose the proper build for the rPi version you are running during the download? I would verify that, and then try to write the image to the SD card again and give it another shot. Give it time, the software has to load on the rPi, detect the ATMega on the HM, flash the atmega then reboot before you see "NO PIT PROBE" on the HM display. If you are watching the rPi on a monitor during this process you should see a lot of text scroll on the screen while the HM software loads. If you never see that happen perhaps try another SD Card.
Last edited:


Sounds like the Pi isn't reading what's on the SD card and isn't booting up. Because it's not booting, it's not able to flash the firmware on the HM board, so let's get that sorted out first.

The row of squares on the display is a good sign and should improve once the HM has been flashed. At this point, there's no need to doubt your soldering job!

Go here and select Latest development snapshot for Version, fill in the WiFi config form and click on Download. Now flash that to the MicroSD card and see if it boots. You should see the green light on the raspi blink rapidly for a few seconds as it boots up. After about 30 seconds go here to see if your HM is listed

Re the 100K resistors. Yes, those are required. They're part of the noise filtering for the probes.

Dusty Hicks

New member
Ok. Thank you so much for the help! I spent the last hour troubleshooting on my own. It ended up being that i installed the wrong version of the HM software, i guess one of them (The Latest Stable Release) is not compatible with the 3B+. Now I got everything to boot up.

Regarding the 100K resistors, Thank you so much! I ended up installing that last 100K resistor and that seemed to make the pit Probe read the right temperature.

The last issue i'm dealing with now is that the (Adapt-a-damper) blower and servo don't seem to be "responsive" for lack of a better word. They blower and servo work, but when i change the fan speed percentage on the controller, it doesn't seem to correlate to any direct change to the servo or blower (i.e. the blower is just constantly going at maybe half speed, and the damper is about halfway open and will sort of open a little bit but i can't get it to fully open or fully close anymore.).. Any advice on troubleshooting the blower and damper? It seems in the assembly video when he has the thermocouple unplugged, the fan stops and the damper closes and when he plugs it it, the fans blows at what looks like 100% and the damper opens. When I plug in my HeaterMeter, the fan is always stuck at the same speed, i can't seem to change it via the Manual fan Mode (when it is on and i adjust the %, the fan speed doesn't actually change, its stuck at the same speed). and the damper doesn't seem to more anymore
Last edited: