Constantly setting set point off.

IvanTrail

New member
My Heatermeter kees going to lid open mode.
It happens immediately after the timer expires, and if I cancel it using the left button, it just sets to off.

Furthermore, it will just turn itsself off (setpoint blank in linkmeter) randomly.

Why is this happening and how do I fix it?

Alternatively, is there anyway to just turn off the lid detection? I have tried setting 0% and 100% for the temperature change and neither works.

Thanks.
 
Last edited:

RalphTrimble

TVWBB Diamond Member
100% is effectively OFF for lid detection.
When the HM turns itself OFF does it say OFF for the set point or does it go blank?
What setting are you running for lid detection?
Are you seeing fluctuations on the pit probe when this is happening?
If all the above are normal you could possibly have an issue with the button circuit (making the HM think the button is pressed left)
 

IvanTrail

New member
It just goes blank in link meter and the pit probe temp goes to [OFF]. Is there a feature that just turns it off if something isn't correct?

Lid detect is 6%/240s now. I changed it back.

I think you may be right because my buttons are acting flaky. I tried the diag menu, which was difficult to get to and the buttons don't seem to map correctly. I have reflashed the ATMega a couple times, then flashed the erase EEProm and let it reconfigure from the pi again. It's been OK for half an hour or so now. Maybe that was it? Dunno.
 

Bryan Mayland

TVWBB Hall of Fame
Yeah it sounds like a phantom button press issue to me. If you're on the latest HeaterMeter snapshot and logged into the webui, you can press N on your keyboard to open up the Noise Graph, then press the "Btn" button and wait for the graph to refresh. It should be 0 all the time, absolutely no variation.

If it does vary, then the most likely cause is the pulldown resistor. Just resolder the connections and make sure the top one here especially has a nice solder joint on it-- that one tends to be the one that causes the most issues, especially on the older PCB revisions. Also I guess hit the pin on the ATmega labeled BTN as well while you've got the soldering iron out.

float-btn.png
 

IvanTrail

New member
Well, I finally had a chance to look this over. I reflowed those joints and dont see any noise on the graph.

I will smoke something this weekend probably and see how she goes.

Thanks again for all the help.
 

Top