Can I rebuild 4.2 Heatermeter with Pi Zero W?



TVWBB Member
I have an older Heatermeter 4.2 with the 4 way button and Pi Model B. My 4 way button is completely dead now, and just today when I set up for a long cook I realized my wifi is broken again. I'm tired of buying these EDI max wifi adapters on amazon. I want to use one of the pi zero w's I have laying around instead. And hopefully replace the 4 way button with something that works better in the process.

Is this possible without buying all new hardware to get a 4.3 board?
Yep. The Zero W will work just fine and if you update the software on the current pi, you should be able to simply swap the sd card into the Zero W and be up and running.
The zero-w will work, just make sure to ONLY install the same number of pins in the zero-w header as you have on your model B (I think 26 pins), if you install ALL the pins on the header the extra pins will hit a transistor on the HMv4.2. You can also move that transistor (and I think the buzzer) to the other side of the HM board, but it is much easier to leave the extra pins off the header on the rPi.
Thank you both. I'll install some headers tomorrow and get this set up. What about the broken button on the heatermeter itself? Can I replace that with 4 buttons? I thought I recalled hearing/reading that you could a while back, but never worried about it because things were half working at the time.
Yeah you can replace the 4 way switch with 4x individual buttons. The bottom right pin of the 4-way should be connected to one side of each new switch (it is the common). Then connect every other pin from the 4-way switch to each individual new switch, apart from the top right (which has no connection on the 4-way). I'm not sure how you'd mount the new switches though.
You might also reach out to John Bostwick, I believe he said he has a bundle of the original 4-way switches on hand and might be willing to sell you one.
Thanks for that info Bryan. I suppose I could rig up some case mount switches.

Ralph that is certainly an option. I guess I was just thinking I don't want to be in the same boat a year or two from now with another bad 4 way switch.
Mine have worked for years, never had one fail. I wouldn't expect that you'll have a repeat failure. I have heard a few reports of button failures, but not many. Have you tried to troubleshoot the issue to determine if it is actually the button failing or perhaps a bad solder joint? Also, maybe John will sell you 2, I think he said he had like 40.
Sounds good. I'll check with him and see what I can possibly get. I was under the impression they were failure prone, but now that I think about it, I don't know why I thought that.

I've got my Pi Zero W soldered up and connected to my HM 4.2 board, but I'm having problems getting wifi going. I wasn't able to just take my old SD card and use it in the new Pi, because my old card was not the correct size SD format for the Pi Zero W. So I downloaded the latest image using the download utility to put in my SSID and everything. I used DD on my mac to copy the image to the an SD card that does fit. I plugged the Pi into my heatermeter board, an HDMi cable into my pi connected to a display, and then the power cable connected to the heatermeter board. All powers up fine. I can watch the console of the pi boot on my display, and the only error I see is an IPV6: wlan0 link disconnected message at the very end of the boot. If I hit enter on my attached keyboard and get dropped to a root shell, I can run ifconfig and see that while wlan0 is loaded, there is no IP address or link detected.

What am I missing here? I checked to make sure my config.txt had the SSID and passphrase in it, uncommented. Do I need to edit /etc/config/network or anything alone those lines?
If you entered your wifi info when you downloaded the image from it should connect, you shouldn't need to edit anything else. SOme have had issues getting the zero-w to boot with the latest snapshot, it is an issue being worked through right now, so far nobody can seem to pinpoint why some zero-w's boot and others dont.... but it kinda sounds like yours is booting all the way if you get the root shell, so that might not be the issue.

Couple things to try, first, disable security on your wifi and then boot the HM, see if it connects, then re-enable security. I had one build that wouldnt connect for nothing, after I dropped security it connected, when I enabled security it still connected... go figure. You could also try the Access Point image, see if you can see a hotspot called "HEATERMETER" with a wireless device like a phone, tablet etc. If you see one then connect, then go to the network config and scan for and connect to your wifi.

If all that fails I have an older snapshot version for AP mode that seems to work on all zero-w's, I can send that for you to try if nothing else seems to be working.
I don't think this is a matter of not working on my zero. I honestly had a problem at first. I was following the heatermeter install directions, and used Pi Baker on Mac to copy the img to my SD card. But for whatever reason, every time I used that when I booted I got kernel panic. It's the whole reason I plugged in my hdmi cable and keyboard. I added panic=0 to keep it from power cycling on panic, and was able to determine it couldn't mount my file system. I couldn't mount it in another linux box I have either, so I just rewrote my SD card using DD on a command line. All worked there, and that got me to the point I'm at now. Linux is definitely booting, and I'm able to get to a shell to do any work I may need to.

I think I'm going to try the AP image and see how that goes. Somehow that seems a little easier than messing with my wifi setup. Thanks and I'll let you know how it goes.

The AP version worked for me. I connected and scanned for my wifi connection to set it up. I think I told the download link that I was using the wrong type of wifi security, so that may have been my problem with the original image. Either way I'm connected and controlling my Green Egg as we speak. All seems good. i'll have to reach out on that replacement button.

Thanks again to all for your help! I'm a happy camper again :)
Thanks Bryan! After using it last night to cook a loaf of bread, I have to say I'm glad I made this change. The web interface seems quicker now. And it's pretty cool that most (maybe all) of my settings stayed in place, which I assume is because they are stored in the arduino side of things. It felt like replacing my car battery and finding out I didn't have to reprogram my radio :)

For anyone else doing this, just make sure you use the right pins. If you solder PIN headers to all of the GPIO spots on the Pi Zero, it mate to the heatermeter board. And if you don't solder pins to the right 26 pins, you're going to have a bad time.

Once again, thank you both for all of your help!
With the HMv4.3 you can solder all the pins on the rPi zero-w if you like, for older HM versions you can only install the first 26 otherwise the extra pins will hit parts on the HM board (which can be moved to the other side of the board if you want to go that route instead). If you look at the rPi there is a box drawn around the place where you solder the header. If you look carefully you will see one corner of the box is cut off diagonally, you need to start installing the pins on that side of the header, 13 per row.
Does it matter if I LinkMeter v13 on the Pi Zero W or do I need to use the development snapshot of v14 to add a Zero W on a 4.2? I thought I read somewhere that it needed to be on the development snapshot but that might only be for the Pi 3 boards. It's funny that there isn't that much HM legacy but we're dealing with a ton of different rPi boards. I guess that's why they call it COTS. FWIW, I did get my 2nd 4.2 built today at lunch (no LEDs or display until I get a case printed) and put my old rPi B model on it and it booted right up and I was able to talk to it!