Results 1 to 4 of 4

Thread: Performer has assist not lighting

  1. #1
    TVWBB Fan
    Join Date
    Jul 2015
    Location
    NOR-CAL
    Posts
    158

    Performer has assist not lighting

    I canít seem to get the speaker to ignite the gas. I can use a match and light it inside the bowl but the igniter isnít doing the job

    I have a spark and even swapped in a new igniter. Stopped short of just replacing the burner because the bolts are so corroded I didnít feel like fighting them.

  2. #2
    TVWBB Gold Member Pat G's Avatar
    Join Date
    Feb 2016
    Location
    Katy, TX
    Posts
    2,691
    Edit: After reading your post again, this will probably not help.

    This helps if the flame is not strong or gets blown out by the wind:
    Check the hose and regulator assemble. There is a small piece of brass at the end of it with a tiny pinhole in it. It is connected to the burner assembly by a retaining clip. The pinhole sometimes will need to be cleaned out using a needle. I'm not sure if this will solve your problem but it might help.
    Performer Deluxe(Copper) Genesis Gold B(Redhead) 18WSM 14WSM 22 OTG JJ Q1200 Gas & Charcoal Go Anywhere, Blackstone 17, Vortex, Kettle Pizza, Smoke

  3. #3
    TVWBB Member Jasper's Avatar
    Join Date
    Aug 2012
    Location
    Twin Cities, MN
    Posts
    36
    Quote Originally Posted by Reggie G View Post
    I canít seem to get the speaker to ignite the gas. I can use a match and light it inside the bowl but the igniter isnít doing the job

    I have a spark and even swapped in a new igniter. Stopped short of just replacing the burner because the bolts are so corroded I didnít feel like fighting them.
    Do you hear an audible click when you press the ignitor button?
    Reason I ask is because I had a sticky button causing it not to spark. My problem was resolved by simply loosening the nut on the button shank.
    22.5" Performer with Touch-N-Go Gas Ignition (CC), Jumbo Smokey Joe

  4. #4
    TVWBB All-Star
    Join Date
    Jul 2017
    Location
    Atlanta Georgia
    Posts
    1,196
    Quote Originally Posted by Reggie G View Post
    I can’t seem to get the speaker to ignite the gas. I can use a match and light it inside the bowl but the igniter isn’t doing the job

    I have a spark and even swapped in a new igniter. Stopped short of just replacing the burner because the bolts are so corroded I didn’t feel like fighting them.
    I just had this very thing happen a few months ago a long lighter would get it lit but the igniter would not. I always thought it was strange that I had to turn the valve so far open to get it lit even with the long lighter. So a week ago went to use it and nothing would get it lit so assume I was out of gas and put a new small tank on it and nothing.

    Tuesday I decided to take it apart as I was not getting any gas, turns out the plastic knob was not turning the valve stem anymore probably had been barely doing it all along I guess. There are 2 screws holding the regulator to the frame, unscrew those and drop it down, look at the valve stem when you turn the knob and see if its turning the valve stem. Mine was at the point it was not so I was intending to pop the plastic knob off and use some teflon tape or something to get it to grab the valve stem so started working it off from behind with a screwdriver gently but after moving it a bit it started to grab so I left it alone it just must have worked it self to far down on the stem.

    Put it back together and bingo gas came on with hardly moving the knob at all and the igniter is working just fine was not getting enough gas before so the lighter would work the igniter would not. You could also try squeezing the plastic knob and see if that works temporarily but pushing it from behind with the screwdriver got it to grip the valve stem. It might be a temporary fix but if it happens down the road I know what it is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •