Thermocouple Noise When Using 2.4G Wifi


 

Gary V

TVWBB Fan
Brian,
Thanks for response. Will insert the lines of code you provided above the EXIT 0 prior to my next cook and see what it does for my noise levels. Sorry I got you started on the dreaded "how do I solve this loop". I used to hate that loop and don`t loose sleep over it. Maybe a few liquid refreshments will disconnect the loop when that time has come.
 

Bryan Mayland

TVWBB Hall of Fame
I've found that manually adding a line to the rc.local isn't necessary because the "Transmit Power" option actually works:
1624028315007.png

Just change the transmit power and "Save & Apply". Switching to 10dBm brought my noise down to at most 2-LSB from as much as 15-LSB in client mode. Before:

1624028489340.png

After:
1624028540762.png

Switching to 5GHz looks the same always, so that's the preferred solution. Note that to switch back to 31dBm (max power) you have to set it to "auto" in the webui then reboot. The Pi wifi module only reports that it goes up to 20dBm, but reports 31dBm if you don't force it to something lower.
 

 

Top