The LinkMeter Snapshot and YOU


 

Bryan Mayland

TVWBB Hall of Fame
Ran into an issue on Xmas while trying to BBQ a roast. I could not connect to my network. I usually do not have any issues with this, but since updating to that latest snapshot I cannot connect. So right now I decided to see if this was an elf playing games or a real bug. It`s real, not an elf pulling my strings.
Now for details. I have a AiMesh network. I use ASUS routers. I can connect to my main router when I have it in the office. When I setup at the grill, it just times out. When I login to router, it see the heatermeter on the Mesh node, the signal is strong, it shows Rx/Tx info, but no connect. Hope this is enough for you to troubleshoot. I downloaded the latest snapshot the same way as always. I am currently on a October snapshot and it connects just fine to both the main and node router.
That's unexpected because the wifi hasn't changed in like 2+ years. I don't believe this is related to the snapshot at all either but more likely a bit of networking weirdness or the wrong firmware image used? All devices I've tested (Pi 3B+, Zero W, Pi 2B + Edimax, original Pi B + Edimax) all work as expected on the latest snapshot.
 

Gary V

TVWBB Fan
Brian,
Thanks for getting back on this. I myself could not see any problems/differences with wifi config file for both versions of the snapshots I compared. Nothing made sense. Both routers were up and running. Both radios were bands on both routers were working and the devices around the house and garage were connected and working. Just the heatermeter would not connect. So I just rebooted the node again and now I am up and running. Not too sure why the heatermeter was showing up in the client list, but would not connect. I guess numerous reboots. 5 to be exact, eventually will get things working again.

Next week hopefully, the Merlin final release will be out for my routers.
 

Bryan Mayland

TVWBB Hall of Fame
Possibly last snapshot of the year and development cycle!
  • [www] Force a graph update if there has been a 15 seconds gap since the last hmstatus JSON was received
  • [www] Reduce EventSource retry interval to 1s to resume a disconnection more quickly on mobile
  • [www] Code cleanup, all var replaced with let on home page
The first one is to address how often when you use your phone to monitor the HeaterMeter, the graph will have a big gap in it where it draws a line from where you left it to the current point and miss all the detail in between. I have code in there to refresh the graph immediately when the page gets visibility again, doesn't always work if the graph doesn't have a lot of unique data in it. The new code forces a refresh if it has been longer than 15 seconds since the last streaming or polled update was received.

The second reduces the streaming status retry delay from 3s to 1s which reduces the delay when resuming the data streaming when you turn your phone back on. Previously it would take a bit before the page would realize it was disconnected, then wait 3 seconds before reconnecting. Between the two, there's a noticeably better experience on Android and iPhone browsers when you unlock your phone after it has been off for a while and the page needs to be brought back up to date.

This snapshot will be up for a few days to make sure it doesn't have any major problem with what I just implemented. After that, the snapshot will be considered "Release Candidate" and no more changes will be made. Release Candidate status will last at least one week, but may be extended if there aren't enough downloads to be sure it gets enough user exposure. If everything checks out, that's v15, baby!
 
I flashed the 12/23 snapshot on the new Pi3/Hm4.3.4 that I just built and am losing customizations upon a Pi reboot. It may be something else I've done incorrectly though. Timezone, CSS, hostname, and interface all revert to defaults.
 
Maybe a permissions issue? I tried to upgrade to the latest snapshot vis URL and downloaded file. I told it to proceed but upon reboot, still says LEDE Reboot SNAPSHOT 20201223
 

Bryan Mayland

TVWBB Hall of Fame
Sounds more like an SD card issue. Check the Status -> Kernel Log for information about errors accessing the device or if the filesystem can't be mounted.
 
So I pulled the SD, deleted the data, formatted, and applies the 1229 I downloaded from the /dl page with wifi supplicant pre-loaded and re-flashed it to SD. When it booted, it still shows 1223 and I have the same loosing config behavior. Maybe I'm seeing some sort of a browser cache issue on the version number?
 

Bryan Mayland

TVWBB Hall of Fame
Yeah Windows is really wonkus about the SD card with multiple partitions on it and it keeps changing how it handles them too. The important thing to note is that you can overwrite the image again with Win32DiskImager but you need to figure out which drive to actually write to.

If you pop the SD card in and it shows up as 3 new drives, only one of them is writable. If you pick the wrong one, you'll get an "Access Denied" error right at the start. In a most unhelpful manner when you get that error, Windows **reorders all the drive letters** meaning if you selected D:\ to write to, it is very likely that D:\ isn't the D:\ you tried to write to the first time. The best thing to do is try one drive letter, if it doesn't work then completely remove the SD card and reinsert it so the drive letters go back to the same that they were the first time you tried, and then pick a different drive letter.

To clarify, if you select D:\, get Access Denied, then try E:\, that's actually probably D:\ again or maybe it is what was F:\. It is a real nightmare when they changed that a couple years ago.

I just know that with my setup, it is almost always the second drive letter that's the writable one. I use the webui System -> Backup / Flash Firmware to update as much as possible because, like Curtis says, its easier than pulling the card out. Just paste the .gz link in the URL box (preconfigured wifi images are not needed when updating).
 

Curtis_Aotea

New member
So it looks like this card is no permanently read only
I find that hard to believe... Have you tried zero-it out in Linux? (how to below).

If you haven't got a Linux box running, download a live usb *nix image, or try a gparted bootable USB recovery image.

Edit: card could have gone bad, micro sd USB reader could have gone bad or have a lock switch on it somewhere.

Try in a Linux terminal:
sudo dd if=/dev/zero of=/dev/sdX bs=1M sync

Where sdX is your micro sd card e.g. "sdc". Needless to say, don't accidentally zero any other drive!!
 
Last edited:
no, I haven't as I don't have a linux box here other than the Pi that I'm putting this into. Maybe I could put RaspOS on another card and use a USB adapter. I did try creating/deleting files in linux via SSH when booted from this card which failed. I also tried using the Raspi imager to write a new image and erase, both failed. Let me see if I can find my usb adapter.

Thanks for the help.
 
Here is what I see from the HM Pi

root@LEDE:/dev# parted -l
Model: SD 00000 (sd/mmc)
Disk /dev/mmcblk0: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 4194kB 24.1MB 19.9MB primary fat16 boot, lba
2 25.2MB 92.3MB 67.1MB primary
 
I tried zeroing it.

6963+0 records in
6963+0 records out
7301234688 bytes (7.3 GB, 6.8 GiB) copied, 198.307 s, 36.8 MB/s

Put it back into my windows system to re-image and still have the 1223 filesystem.
 
I put back in my linux system and used cfdisk. I deleted the partitions, did a write and it said there were no partitions. I exited and re-started cfdisk and they are still there. What could I have done during the initial image write to cause this?
 

Gary V

TVWBB Fan
ran into this issue before Christmas. My snapshot somehow wrote to a different partition than normal. The only way out for me was to go to disk management in Windows and delete all partitions on the sd card there. After that I formatted using SD Formatter and then installed image and everything worked correctly.
 
Thanks for the reply. I tried deleting the 2 partitions I see in both windows and linux. It says successful but if you remove and reinsert the card, they are back. Somehow I've made the card read only. It is a micro SD so its not the full size card with the switch.

Thanks again for all the help.
 

RalphTrimble

TVWBB Diamond Member
I have seen micro SD cards get locked in read only before, never did find a fix for it, at some point you've gotta look at the cost of the item and the time you speed fixing it.... and just buy another card! I'd suggest a different brand/model.
If you search the web for this topic you will find others posting about it (it's not just a heatermeter thing), I like the good old slider switch on the bigger cards better than the digital lock.
Quick web search will return lots of methods to clear the read only, not sure if any really work?
Good Luck!
 
Thanks Ralph, good to hear from you! Hope you're well. Yeah, I used another card and it went fine, I just didn't want to brick another one buy doing something wrong with the partitions. I just really wanted to understand what happened. I did try some things I googled but no luch.

Thanks again, now to figure out how to put a more modern pi on a HM 4.0! Pi3B won't fit, maybe a compute module.
 

Top