Issue with old HM 4.0


 

Troy Gamm

TVWBB Fan
I haven't used the HM 4.0 (Raspberry Pi 2B) in over a year since we were traveling in a 5th wheel after we sold our house last year. I plugged it in at our new house and couldn't get it to connect to the wifi. Steps (some mistakes) I took:

-Tried a wired connection: Failed
-Connected via HDMI to my TV then powered it up: TV said no signal
-50% of the times I would power it up the blue light on my Wifi dongle wouldn't come on
-Downloaded the latest HM software and used ApplePiBaker to burn onto a working 4GB SD card and powered up but couldn't get it to boot from the SD card and load the new software
-Used the joystick to do a reset config (Mistake): now the display shows "prob 3 ~180º" instead of "Ambient 75º
-Still can't get to it from a webpage
-Used ApplePiBaker to burn a Raspberry Pi OS onto the SD card
-Used the Pi OS SD card to boot up and it takes it and boots up and I can see it pulling an ip address from the wired connection so I created a DHCP lease on my router for that IP address
-EVERY time I use the Pi OS SD card and power it up, the ethernet port and Wifi dongle and activity lights come on and it pulls an ip address, although I still can't get to the HM page from that ip address.
-EVERY time I use the HM SD card, I get no activity light, no ethernet light, no wifi dongle light and it doesn't pull and address although the display still shows no pit probe, prob 3 ~180º.
-I have tried version 14 of the HM firmware loaded onto an SD card but it still doesn't boot from it.

It seems like it doesn't want to recognize the HM burned SD card to boot from it but it does from the Pi OS SD card.

Not sure what to at this point. I have a USDA Prime brisket in the fridge and was planning on smoking it this weekend.

UPDATE:
Really wish I had thought to check the 8 year old 12V adapter. Since I have been using the micro USB to power it for the past couple of hours while trouble shooting with and without the HM board attached, I finally removed the USB power and plugged in the 12V adapter that seemed like it was working to at least give it power this morning. Now, no power when I use it on the HM board. I put a meter on it and it shows a decreasing voltage starting around 2v and decreasing the longer I leave the meter on it. DAMN

So right now I have it powered by the micro usb, and connected via the ethernet port to my switch. the HM display still shows the same no pit probe and prob 3 ~180º. I enabled SSH on the Raspberry so I can SSH to it from my laptop. I configured the Wifi via SSH and now have both the wired and Wifi interfaces up and passing traffic. The Pi can get to the internet but I still can't bring up the HM page in a browser.

For the lights on the Pi board, when I power it up with the Pi OS Sd card, I get the red light and then green which stays one throughout the boot process. At somepoint during the boot process, the ethernet lights come on and the blue light on the Wifi dongle comes on. When I power it on with the V14 or V15 HM SD card, I only get a solid red light with no green at all and no blue light on the Wifi Dongle.

Should I be able to get to the HM webpage when it is powered by the Micro USB?

It's time for some Single Malt! What a freaking day.
 
Last edited:

Troy Gamm

TVWBB Fan
Ok, maybe it was the scotch but I ended up revisiting and got it figured out. Aside from the bad power adapter, Even though I have a Raspberry Pi 2B, I needed to select Raspberry Pi A/B/Zero/Zero W/A+/B+ from the dropdown menu on the HM downloads page instead of the Raspberry Pi 2/3/3A+/3B+. It was probably the only thing I haven't tried today. So I got it sorted out and is working like champ now. Ordered a new Power Adapter from Bryan today so I should have it in a few days.
 

Top