Cannot access HM

Steve Conway

New member
Hello,

I built a HM about 4 years ago. Haven't been cooking much but am getting back into using it again. I cannot get it to connect to me network. I just reset all the software, plug it hardwired to my router, and it is not getting an IP. The light on my router isn't even lighting up. I think I just killed my HM because I reinstalled the software from the beginning thinking that was it. Now I'm thinking it is my retro pi that is messed up.

Any suggestions?
 

Bryan Mayland

TVWBB Honor Circle
It would probably be easiest to start from scratch. Pull the microsd out, download the latest snapshot (get the right one for your pi model) with your wifi info baked into the image and boot it all back up again. If still nothing, watch the LEDs on the Pi itself as it boots. The activity light will:
  • Blink like crazy about a second after power up as the kernel loads
  • Blink fast for 5-10 seconds (preinit)
  • Blink slowly for a 20-30 seconds (services loading)
  • Turn steady (either off or on). Booting is complete and it should have gotten an IP address within 2-3 seconds of this point
 

Steve Conway

New member
Thanks Brian. No go. I reinstalled the image and put it back in. I noticed that activity light on the PI flashed twice green and stopped. I plugged the HDMI into my TV to see if it showed anything. It is showing a gradient image on the screen. Red in the upper left, yellow in upper right, blue in bottom left and cyan in lower right. I even removed the HM from my PI and just powered the PI directly and I still see the same image on my TV.

Do you think my PI is toast?
 

Steve_M

TVWBB Guru
The rainbow gradient means that the kernel isn't loading properly. I would try a different SD card. I think the RasPi is ok.
 

Steve Conway

New member
I tried another card. A 4GB card. I used SD Formatter to format the drive. I downloaded the hetermeter image (28,800KB). I used Win32 Disk Imager to write it. Same issue. Green light comes on, goes off, blinks, and nothing else. When I look at Windows on my SD card, it shows that the card size is only has capacity of 18.9 MB and that I'm using 9.28 MB. When I use Windows Explorer and browse to my SD Drive on my computer, it really does look like only 9 MB of data on the SD card.

Could that be the probably? The image file is pretty darn small as well. Just not sure why it shows only 18 MB capacity. Maybe because it is formated with FAT32 and windows can't see the full 4 GB.

If I did that correct, then maybe my PI is hosed.
 

Dupree

TVWBB Fan
Make sure you have the right version os for the Pi and HM board. When I saw the rainbow screen last week on my initial build it was due to version mismatches. Once I matched up this os to the pi that screen went away.
 

Steve Conway

New member
I believe I did that correct. I have a Raspberry PI 1 model B. I picked the second option for target board. Raspberry Pi A / B.

I think I'm going to try and disconnect the PI from the HM PCB and install some other light weight image to see if that works. If not, I think my PI is dead.
 

Steve Conway

New member
I loaded the Raspberry PI OS and it worked just fine! I went back my newer SD card and used SD Formatter. I only did Quick Format before.

I did the Overwrite Format and it worked this time. I retried it on my original SD card and that failed. So it looks like it was the original SD card that failed. The new one works once I figured out how to format it!!!

Thank you for helping.
 

Top