Back To Using Heatermeter

Tim McGee

New member
Hello,

My smoker has been down for a while for a new outdoor kitchen build. I'm ready to put the smoker in it's new home but I'm having some issues.

Bought and assembled the kit two years ago: HeaterMeter v4.2 Kit - Thermocouple PCB / No Blower / Model B

I've changed routers since the last time I used the HM and it's a different subnet. It's google wifi so I don't have ability to set the subnet. Spent a bunch of time trying to change the subnet. Was successful at one point, got cocky trying to tweak it a bit and now it's hosed. One of the things I was trying as a fix was preventing the fallback and lan interfaces from coming up on boot. Yeah, I knew that I shouldn't do that, but. So now it can't connect on the wan and the lan is essentially disabled.

So I'm thinking maybe there are some new upgrades etc I should take advantage of and just blow it out and re-install the software. Does that seem reasonable? Is there a specific release I should be looking at given the hardware I purchased?
 

RalphTrimble

TVWBB Diamond Member
I would download the latest snapshot release from here http://heatermeter.com/dl , just make sure you choose the right target board to match your rPi. You can set the wifi info before the DL and upon install it should just connect automatically. If it does not then you can use the reset config from the HM menu which should put your net config back to default so you can manually start from zero.
 

Patrick Steele

New member
I, too, have a Heatermeter and Google Wifi and I'm running into issues with port forwarding.

I can see the HM just fine locally in my browser, but remote connections do not seem to work. I created a static IP for the device, then forwarded the port (80>80 and X>80) and tried rebooting the router multiple times. Regardless of what I do, there's no remote connection and it simply times out. I've tried the IP directly and IP:External Port without any luck. When I configure the forwarding I do it for TCP/UPD (can also set it for one or the other).

Any ideas?

Running:
Heatermeter 4.3 on v14
Raspberry Pi 3
 

Patrick Steele

New member
I am not sure, to be honest. I also tried 8080 (external) to 80 (internal) to no avail. I'm a Comcast/Xfinity customer.

Edit: Right now I have it set up for:
Static IP for device.
Port 8080 External to 80 Internal

Rebooted router and while it all works internally just fine I can't see it externally.
 
Last edited:

NickB-MI

New member
Necro-post

I recently built a HM v4.3 with a pi zero w. I am running a Google Wifi system and was having issues with port forwarding as above. I set up a noip account and placed a noip DUC on a raspberry pi printer server on my network. Once i rebooted the Heatermeter I noted the network address and reserved a static IP in the Google Wifi app. Once that was complete I configured port forwarding on port 80 and checked the port via Open Port Check Tool. Hopefully I can post a cook this afternoon once I buy an adaptor for the Adapt-a-damper!

Great community and thank you for the awesome resources!
 

RalphTrimble

TVWBB Diamond Member
Maybe they have a total block on port 80? Try adding an additional listening port on the HM so you don't have to forward 8080=>80, add 8080 to your HM so you can route 8080=>8080 instead. Not sure if this will fix, but worth a try....
Go to Config/Services/uHTTPd tab in the HM, in the HTTP Listeners section, click the green + to open a new line and put 0.0.0.0:8080 in there, then hit the Save and Apply button. This will allow your HM to communicate on both port 80 and 8080 (or whatever port you choose).
Good luck!
 

Top