WiFi issues

Jeff OBrien

New member
I have a hm 4.3 with a raspberry pi 3 B+. This is a new build. I got the already assembled hm so I doubt that’s the problem. I’ve tried all three ways to install the software and can’t get the hm to connect to my WiFi. I’ve plugged it directly into my goggle WiFi hub and still nothing. Any input will be greatly appreciated.

Thanks Jeff
 

Bryan Mayland

TVWBB Honor Circle
If you've got an ethernet cable and a port on your router, then the easiest thing to do would probably be to just use the latest development snapshot for the 3B+ and choose wireless mode: default on the download page. That will set it up as an Access Point named heatermeter but more importantly won't have any other wifi config. Then plug it in to the router and boot it up and wait for it to get an IP address. Go to that address, login, and use the LinkMeter -> Wifi page to scan for your wifi and connect to it. After that, unplug the ethernet cable (you can't have both at the same time and have both work), reboot and you should be good to go.

You don't mention any other details about what you've tried so here's just some generic tips. If you still need help, let me know what exactly you're doing and maybe I can spot where things are going wrong.
-- Make sure you're using the "snapshot" and not "release v14"
-- Make sure you've got the image for bcm2709 or rpi3 (depending on which you downloaded) and not bcm2708/rpi
-- Be sure you flashed the image using Win32DiskImager similar and not just put the file on the SD card
-- Watch your Pis LEDs on boot. You'll see it flash a bunch randomly, then flash fast, then slow, then go steady indicating it is fully booted. If it just flashes in a pattern from the beginning or doesn't flash at all, you've got the wrong image, copied to the card instead of writing it, or the Pi can't read the card.
 

Jeff OBrien

New member
I’ve been downloading the v14 every time. I’ll try the snapshot this afternoon. I’ve been using win32. The red light on the pi flashes four times then four times faster then goes steady then repeats. I’ll let you know if it works this afternoon.

Thanks Jeff
 

Bryan Mayland

TVWBB Honor Circle
Yeah nobody every notices that it says "Note v14 stable does not support the Pi 3A+/3B+ (2018)" which then means that the snapshot has to be used. I have plans to change the way the page works so you select which Pi you have as the first step and then it only gives you options to download firmwares that work for that device, instead of the way it works now in which you select the version then the target. I think it would make a lot more sense that way since that's how a user would think about it.

Glad you're up and running!
 

Top