pi2 wifi troubleshooting help?

Dan-D

New member
Hi.
New owner of a heatermeter here.

I'm coming from an ikamand unit for my KamadoJoe. I wanted somthing where i would have the ability to remote cooks but dont need to rely on my phone to check whats going on.

This was my first time soldering, Other than accidently melting the top of the 5 pin plastic riser on the 2nd last step, things went pretty smooth with the build, and was pleasantly surprised when it properly booted and the buttons/menus worked. I have i plugged into a spare pi2 i had collecting dust.. The only thing is, wireless wont work. I tried both a realtek usb adapter and an edimax ew-7811unv2 mediatek adapter, my regular as well as guest wifi, as well both stable and the latest build.

ifconfig shows me only loopback, eth0 (192.168.200.x) but no wlan0.

When i tried a different OS on the pi2, both adapters work fine. Any ideas ?

Not the end of the world, I had lent a pi3 to a friend and i found out he's not even using it. I'll be picking it up this weekend worst case scenerio. :)
 

Steve_M

TVWBB Guru
The wireless drivers are more stable in the latest snapshot. If you still don’t see the wlan interface then it’s safe to say the hardware isn’t compatible with the HM image.
 

Bryan Mayland

TVWBB Hall of Fame
Yeah the list of wifi chipsets that are supported is very small, just 3. To see if the wifi adapter you're using is working then do a `iw list` and see if it shows up. If it doesn't show up there, then nothing is going to work. If it does list the adapter there, then we can try to figure out what's not working in software (the config scripts) at that point.
 

Dan-D

New member
Hi Bryan.

Thanks for creating and supporting such a cool project.

Unfortunately, 'iw list' shows nothing on the 3 different usb wifi interfaces i tried. (i dont need to reboot between each try do i?) In the console I noticed the kernel msg saying it discovered the chipset for each as you plug them in.

I guess im SOL with this pi2 unless i buy another possible wifi adapter ?

No worries, i can wait another day or 2 until i grab my pi3 back from my friend.
Besides, im still waiting for my servo motor to come in the mail so i can build out the damper :)

ps, coming from a total noob with regards to soldering, your instructions and build video were super helpful.

Cheers,
-Dan
 

Bryan Mayland

TVWBB Hall of Fame
You should reboot between trying the different adapters. The hotplug support on OpenWrt/LEDE is pretty rudimentary (and in fact it just loads every single kernel module that's on the filesystem at boot) so it might not automatically create the interface. The line you're seeing in the kernel log is probably just the USB device descriptor report and not any useful module attaching to it.
 

Top