Help - HM4.2.4 + RPi Model B - No network or USB wifi



New member
Hello. Hopefully someone can provide me with some guidance here.

I built this 5 years ago (+/-) for my smoker. My heatermeter has been working great, up until a few weeks ago. Everything still functions except networking. LAN and WiFi will not connect, no lights, no link, no IP, no network information showing up in the display, etc.

I have tried two different wifi USB adapters that have worked on this heatermeter in the recent past (6 months ago). tried plugging into my router with two different (known good) eth cables. - no go.

I downloaded the latest firmware (v15) today and used ApplePi-Baker to restore the image to a new SD card - same issue; boots up, heatermeter display and probes work, but no network.

Seems odd that both the USB ports and LAN port would fail on the RaspPi, but that is where I am at the moment.

Any thoughts/suggestions on further troubleshooting this?

I read that Model A or B (original), Zero/Zero W or Model A+ (with three minor mods) will work. Will any others (newer?) work?

This is not a complete showstopper as I can still run my smoker, but not having the web interface and remote control capability is not great.

Thank you for your time.

I ordered a new RPi ZeroW (2017) and my heatermeter "came back to life". However, on a reboot, I was getting "unknown" on the HM screen instead of an IP address. Sooo, I thought it would be "smart" to "reset config". Not so smart. Now the RPi does not boot at all, and my HM is set to defaults and thermocouple, PID is wrong, cant get to the webui and fix the config. Was hoping to smoke a pork butt this Thursday but that is not looking good now.
I have RMA'd the RPi Zero, but the new one will not be here in time.

Anyone have a built HM 4.2 kicking around that they want to sell? Guessing something is wrong with my HM causing the RPis to die.