Can't Connect to Heatermeter by Ethernet or Wifi


 
Haven't touched my Heatermeter since 2018. Brought it out with the intention of doing a cook for turkey day. I have since moved to a new place and knew the wifi settings would be out of date.

Unit turned on without any issues. It didn't hook up to wifi and I waited till an IP address appeared on the LCD (198.168.200.1). The heatermeter was the last thing I hooked up to previously by Ethernet so I did not have to change my laptop ethernet settings. I hooked up my LAN cable and was able to hit the heatermeter and see the graph cook screen. I tried to login to the unit but did not remember the password I put on it.

I followed the steps on the Github repository and reflashed the SD card with my wifi settings. When I tried to access the unit it shows a no DNS failure. The wifi settings are correct in the config file.

I have a Rasberry Pi model B. Silkscreen on PCB says 2011.12.

Any ideas on what I should try next?
 
Scratch that I figured it out.

The config file kept adding single quotations to my SSID and password. It would also comment it out. Made the required changes and the no restore command on the separate file and that did the trick.

Now on to making sure the blower works!
 

Bryan Mayland

TVWBB Hall of Fame
The boot process comments it out once it uses the value from the config.txt, to prevent it from overriding the wifi settings on every boot (which would prevent the webui from being able to change it). The quotes added are there to try to preserve any spaces in the password, but depending on how complicated the ssid/password are, there may be issues.

It is pretty tough to go from web form to shell script to binary image to text file to shell script to Lua to config file to shell script to config file to actual wifi process and preserve each steps escaping to accept all possible values 😆
 

 

Top