Hosed something up...


Bryan Mayland

TVWBB Hall of Fame
Yup I can confirm there's a problem with the snapshot image that's unrelated to the configuration bug I fixed last week. There is a missing luci module that's preventing some of the pages from loading. For my own reference, this is the error
/usr/lib/lua/luci/dispatcher.lua:384: Failed to execute cbi dispatcher target for entry '/admin/system/admin'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:49: Failed to execute template 'cbi/map'.
A runtime error occured: /usr/lib/lua/luci/template.lua:49: Failed to execute template 'cbi/tsection'.
A runtime error occured: /usr/lib/lua/luci/template.lua:49: Failed to execute template 'cbi/ucisection'.
A runtime error occured: /usr/lib/lua/luci/template.lua:49: Failed to execute template 'cbi/network_netlist'.
A runtime error occured: /usr/lib/lua/luci/model/network.lua:10: module 'ubus' not found:
	no field package.preload['ubus']
	no file './ubus.lua'
	no file '/usr/share/lua/ubus.lua'
	no file '/usr/share/lua/ubus/init.lua'
	no file '/usr/lib/lua/ubus.lua'
	no file '/usr/lib/lua/ubus/init.lua'
	no file './ubus.so'
	no file '/usr/lib/lua/ubus.so'
	no file '/usr/lib/lua/loadall.so'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:384: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:139: in function </usr/lib/lua/luci/dispatcher.lua:138
I'll see what I can do about getting this built, which might be tough considering the ubus module may not be available in the version of Attitude Adjustment the WRT54GL uses. I'll get a solution though.

EDIT: Yup the newer luci needs libubus-lua which isn't in the flavor of Attitude Adjustment LinkMeter for WRT54GL uses. I'll either have to try to get the latest AA running on it or backport the package orrrrr welp those are the only two options really. Either way, it's a big deal. As Nick said, you can still configure the networking manually, the web interface just doesn't work.
Last edited:
After bricking my router, I tried using an AA release candidate + installing linkmeter packages, that was a no go. I tried to flash the 03 .trx off capnbry.net again via ssh just a few minutes ago, and it flashed successfully.

Linkmeter graph loads up, but config page gives me:

/usr/lib/lua/luci/controller/admin/uci.lua:7: bad argument #1 to 'unpack' (table expected, got nil)
stack traceback:
[C]: in function 'unpack'
/usr/lib/lua/luci/controller/admin/uci.lua:7: in function 'v'
/usr/lib/lua/luci/dispatcher.lua:506: in function 'createtree'
/usr/lib/lua/luci/dispatcher.lua:168: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:139: in function </usr/lib/lua/luci/dispatcher.lua:138>

The troubling part is that I can't set a password so I can't ssh in, so I'm not entirely sure how I am going to recover when whatever is broken in the snapshot gets fixed (short of tftp I guess).
Last edited:

Bryan Mayland

TVWBB Hall of Fame
Yeah I am working on it. It is a little slow going because it takes like 20 minutes to test each change I make, only to find that I need to fix something else. I'm not even sure the AA-rc1 will even work reliably once I get it running, based on the CPU speed and memory issues they've identified but I am hopeful I can get it working.

Most likely the SDHC driver will have to be removed to try and make up the difference. It takes between 256k an 512k of RAM and I think that might be the straw that breaks the camel's back. We'll see though, I've got a full rebuild going now so that's an hour before I can tell if it is going to work.
I appreciate you trying to get to the bottom of it. I should have left well enough alone until I had my rPi build done, but you know how that goes. :)

Bryan Mayland

TVWBB Hall of Fame
Welp I've got the image up and running. However, even without the sdcard driver there's just not enough RAM to run the webui. There's about a meg and a half and once you start hitting web pages, it will just crap out the whole router. I'm not quite sure where to go from here. It has always been close on RAM and with the latest OpenWrt, we've just run out. I shudder to think the only option is to fall back to OpenWrt Backfire then try to backport all the fixes to that release. That will take time I just don't have right now.

If anyone wants to take a look at it and maybe find a solution, I've pushed the working image to http://capnbry.net/linkmeter/snapshots/trunk/

J. Winn

well that stinks :-/...I should have just left well enough alone I guess. Is there any way to just go back to where it worked or at this point no?
Yeah, I don't personally care about being on the latest OpenWrt or anything, I just want to be up to date on Linkmeter functionality. At this point, I'm more than fine with any sort of OpenWrt as long as I have something running Linkmeter alarm code.

Edit: I've managed to get a non-broken (meaning I can actually set a password) openwrt image up on my router, so not all is lost once we figure out what image will run linkmeter w/o exploding. :)
Last edited:

Bryan Mayland

TVWBB Hall of Fame
The only reason I moved forward was because LinkMeter needed a bug fix from LuCI, which then required netifd, and so on in that manner until it became easiest to just try and get AA working than to try and backport all the fixes to our (randomly selected) revision. There was a chance it would have worked, because we were actually on AA already, just a year-old revision.
So I'm sort of an OpenWRT noob, do they not do different images with different feature sets? I run dd-wrt on my home routers and they have different images for micro installs, vpn, etc.

Sadly, even though I am a unix guy I don't know how much use I'd be at firmware hacking. :(

Bryan Mayland

TVWBB Hall of Fame
I think they just do a base image then it is up to you to install the packages you want. OpenWrt a million times more friendly to installing your own packages vs dd-wrt, which is why dd-wrt makes the different pre-made images. The image I put out is custom to include all the needed packages and default configuration without any extra cruft.
Well, if that's true and the image you are already building is as barebones as it can be and still support linkmeter, well that sorta blows. I can't imagine the Linkmeter code adds that much overhead. I did notice that LuCi was dog slow on my WRT54G even w/o any Linkmeter stuff on top of it. Seems crazy that they can't even get a basic web interface to run smoothly on these things.
Bryan, do you happen to have an older image laying around (like pre-alarm code days) on the older AA build? I'm thinking of doing some smoking over the holidays but at this point I'd be doing so the old fashioned no fun way. :)

Bryan Mayland

TVWBB Hall of Fame
I sure don't. I was planning on attempting to roll back to the old version manually and doing a rebuild but I've been too busy to get it sorted out.
Heh blast. I was hoping I had one laying around still, but I didn't. No worries, I'll post in the other thread to see if anyone else has one laying around. Hopefully you'll get something sorted out as time allows. Appreciate it!

D Peart

I have this one from March 9th. Not sure if it is "correct". I can't remember if I have to use the wrt54g or wrt54gs, it's whichever one isn't typically posted :)


J. Winn, if you want I can toss up the image I got from D. Peart, it works ok. It's older, so it's missing some features I liked (like time to completion), but it's better than a bricked HM.