Tried updating snapshot and have trouble. Did I do it wrong?


 

RKHanso

TVWBB Fan
I have an old 4.2v of the heatermeter. The firmware had a 2019 date. I took a chance and downloaded the latest snapshot from here: https://heatermeter.com/dl/
In the web GUI (over WiFi), I went to the AVR Firmware tab, selected options to update and pointed it to the new disc image file I downloaded. It uploaded and said it was successful and I still could connect to the Heatermeter.

But I get no data, with it saying Serial Connection cannot be established. No Communication can be established. Did I do something wrong? Do I need to update by taking the SD Card out and flashing it again? And I now see in this thread that there are firmware downloads now instead of snapshots. Is one better over the other? Not sure what to do since this has been working well for a long time and I've been out of the "building" game.
 

RKHanso

TVWBB Fan
It's really hosed up now. Won't show the Web GUI at all after I used WinDisk32Imager to install heatermeter-bcm2708-stable_14 on the SD card and boot the Pi (Model A+ v1.1).
 
Last edited:

RKHanso

TVWBB Fan
It's working now. I used the other flash image and it picked up a new IP address.
Will work on getting it all set up again.
 

RalphTrimble

TVWBB Diamond Member
Glad its working again. On the HM DL page make sure you select the proper options to match your rPi version before you dl the update.
 

RKHanso

TVWBB Fan
Well, it's still not working.
I have a Pi A+, so I'm using that verson.

Still getting
No Communication
HeaterMeter serial communication can not be established. Configuration requires bidirectional serial operation. Possible causes of failure:
  • No HeaterMeter board attached
  • No HeaterMeter (AVR) firmware installed. See AVR Firmware
  • Incorrect baud rate in /etc/config/linkmeter
  • Hardware malfunction
 

RKHanso

TVWBB Fan
After getting the GUI to work again, I tried flashing the firmware through the GUI again. This is the result:
Stopping LinkMeter OK

LinkMeter platform is BCM2708
Loading SPI modules...
AVR fuses ffd705 OK

01aab97b93254445e1ae13dba071b0b7 /tmp/hm.hex
hmdude: compiled on Oct 12 2017 at 13:13:56
hmdude: invalid record at line 33152 of "/tmp/hm.hex"
Using port: /dev/spidev0.0
Update successful
Starting LinkMeter OK

HostnameLEDE
ModelRaspberry Pi Model A Plus Rev 1.1
Firmware VersionLEDE Reboot SNAPSHOT r4558-438dcbfe74 / LuCI lede-17.01 branch (git-17.100.70571-29fabe263)
Kernel Version4.9.34
Local TimeSat May 28 22:05:00 2022
Uptime0h 1m 58s
Load Average0.26, 0.16, 0.06


System logs: https://hatebin.com/bqbfkpemqi

Kernel Logs: https://hatebin.com/nqoijfevru

AVR Firmware tab:
1653775707325.png


And the configuration page is still giving the same error:
1653775765510.png
 

RKHanso

TVWBB Fan
On the front of the Heatermeter, the Green and Yellow LEDS are on solid and the top row of text boxes in the LCD Display are all blacked out. The bottom row is blank.
 

RKHanso

TVWBB Fan
It's working now. I did this:
LinkMeter -> AVR Firmware -> Bundled -> hm.hex -> Flash

Is there anything else I need to do?
 

RalphTrimble

TVWBB Diamond Member
Going with the bundled version writes the version you have from your current installation I believe, meaning, does not upgrade. Also, there are two places in the HM where you can push updates. Instead of Linkmeter\AVR Firmware try this:

DL the latest release (looks like release v15 is newer than the snapshot right now), select your rPi version and then click the Download.gz link, save the file where you can find it.

Go into HM configuration and navigate to SYSTEM - Backup / Flash Firmware

Under Flash New Firmware Image click Choose file and select the file you DL'd above

Click Flash image

After a brief delay the HM should report that the image has been uploaded and ask you to confirm you want to flash your HM. Click PROCEED and your HM should update, it went really fast on the two HM's I just flashed.

Good luck!
 
Last edited:

RKHanso

TVWBB Fan
Thanks Ralph. I followed your procedure above. I downloaded the software for the A+, Zero, etc.

After the upgrade steps were completed, the web GUI said the firmware was being updated and don't remove power to the Heatermeter. Wait a few minutes and I may have to refresh the browser..

I couldn't get the Heatermeter web GUI to load again. The Heatermeter never joined the WiFi network again, even after waiting 10 minutes.

The Heatermeter itself shows this on the display (even with NO temp probes connected): Pit: 0F 0%

I later rebooted the Heatermeter anyway and now it will connect to WiFi and I can access the web GUI. Though the display on the Heatermeter itself still says the same thing. Shouldn't it say "No Pit Probe" when there isn't one connected? Or maybe the newer software/firmware doesn't do that? It seems to be reading temps fine though.
 
Last edited:

RalphTrimble

TVWBB Diamond Member
Sounds like the IP address on the HM may have changed? Reboot the HM and watch the screen, it should display the IP address when it connects, then try to connect to the GUI on that IP. You can also go to https://heatermeter.com/devices/ from a computer on the same network and it should show the HM and it's IP address there.
I am not sure about the "No Pit Probe" question, never seen "0F 0%" displayed personally. My guess is the pit probe configuration is not (or no longer) correct. Once you get logged into the GUI check out your probe configuration...
 

 

Top