How to get auto time Update to work in HeaterMeter v4.0 for RaspberyPi / Standalone


 

Dale Ward

TVWBB Fan
Bryan,

Almost got mine finished but have noticed it wont automatically get the time, every reboot it is off. and does not seem to correct it self. Does it take a long time to update?

Also when Monitoring from my kindle fire using Firefox the graph blinks like once per second or so. It does not do this when using the silk browser(built in browser on kindle fire)

Love this Project thanks so much for all your hard work.
 
Last edited:

Bryan Mayland

TVWBB Hall of Fame
Because there is no real time clock on the RaspberryPi, the time is fetched during bootup (after network initialization) via NTP. For this to happen, the device (rPi) has to have internet access. Does it have internet access? By the time the website is accessible, the time should be set.

The blinking is caused by the graph redrawing. Firefox on Android's HTML5 canvas actually renders, then scales and rerenders it seems so what you're seeing is a slightly-different-scaled version of the graph for a split second before it goes back to normal. If you zoom in just a bit, the graph will stop blinking but the scrollbar will blink every time there's an update. I'm not a web developer so I don't know what the proper mobile meta viewport settings or different way of rendering can help Firefox not be silly. For me if I refresh the page it stops blinking, but if I zoom in then back out, it blinks again. It isn't really something I can figure out how to work around.

That said, rendering a 2400 point transparent graph every couple of seconds and scaling it to fit the screen all while modifying other DOM elements is a pretty amazing feat. It shocks me how much CPU power these tablets and smartphones have.
 

Dale Ward

TVWBB Fan
What a quick reply!!

Yes it is hooked up using the wifi and has internet access no problem.
Looks like it is updating but strange it is 10 minutes fast.
 
Last edited:

Bryan Mayland

TVWBB Hall of Fame
You may want to check on the Network -> Diagnostics page if you can ping 0.openwrt.pool.ntp.org. If so then check Status -> Processes to make sure ntpd is running. Finally you can check the System -> System page to see if the NTP client is enabled. Beyond that, I can't think of any reason why it wouldn't set the time properly.
 

Dale Ward

TVWBB Fan
Checked and can not ping any thing from the diagnostics. I am using wireless though dns server for access, so it is somewhat online. just sent you pm for access to it if you have time.
 

Bryan Mayland

TVWBB Hall of Fame
You've got your network interfaces set to static IPs but didn't give them any DNS addresses. I added 192.168.0.1 to the list and hit apply but now I've lost contact with your device. You may need to reboot it for the change to work? Also I'm not entirely sure how much openwrt likes having 3 networks set up all with the same IP address and on the same subnet, even if 2 of the 3 aren't technically up.
 

Dale Ward

TVWBB Fan
Ok got back in but looks also put it in DMZ so think it might be port forwarding issues in my router
I have port 80 opened up and 118 to 124 open.
What do i need forwarded to it?
Is it safe in DMZ?
 
Ok got back in but looks also put it in DMZ so think it might be port forwarding issues in my router
I have port 80 opened up and 118 to 124 open.
What do i need forwarded to it?
Is it safe in DMZ?

You wouldn't have to forward anything to it, all it needs is the ability to send out a request on port 123. A couple of things I had to do are:

1) make sure your network settings are all correct, you need to have
IP address
Subnet Mask
Default gateway
DNS Server
If you are missing any of this, it won't work

2) Enable the NTP option
3) use a known good NTP server like pool.ntp.org

Then reboot the RasPi

If this doesn't work, let me know and we'll troubleshoot the network configuration.
 

Dale Ward

TVWBB Fan
I had to re-image Mem card and put in new settings as it got confused and would not allow any access, on boot it would not display any IP address.

OK the reason for the port forwarding is for access from, my cell or any place I have web access. I removed the DMZ and left port forwarding for port 80 to the raspi. The problem seemed to be not having the DNS server set up put DNS it to Google and it works great.

I'm i correct that I need to port forward to is since it is behind my fire wall?
 
Last edited:

 

Top