HeaterMeter initialization

Ken Ba

New member
I haven't used my HeaterMeter in a while, and in the interim I replaced my Wifi access point. forgetting that would be an issue, I plugged it in, and I noticed that there was no initialization routine (no blank screen for several seconds as I had remembered there being previously). the screen opened immediately to the Pit 1 temperature, as soon as I powered it up.

I attributed the lack of the initialization routine to having an invalid Wifi name in the config file. I removed the SD card and edited the file with the correct Wifi name and password. still no initialization routine and no wifi connection. I tried another wifi access point in my house and again, no connection.

does the processor on the heater meter board need to be reset in some way?

thanks

ken
 

RalphTrimble

TVWBB Diamond Member
I would go to heatermeter.com/dl, select your rPi board version and dl the latest snapshot build including your wifi setup (make sure you use the DOWNLOAD button on the bottom to dl, not the gz or zip links at the top). From there you can either connect to your HM via LAN to update or remove the SD card and write the image to the card,
After this new build is flashed to your HM it should connect to your new wifi automatically.
 

Bryan Mayland

TVWBB Hall of Fame
Just for reference, the HeaterMeter's LCD is completely independent of the Pi and is fully up and running before the Pi even starts to boot, so there's nothing going on between them for at least 30 seconds when the Pi announces the IP address to the HeaterMeter.

You should just be able to edit the config.txt and put the wifi information in (remove the # at the beginning of the line on any line you edit!), or just use the download page with the wifi information already built in, as Ralph suggests. It does take a minute for it to connect to the wifi so make sure you're waiting long enough too.
 

Ken Ba

New member
if the RPi is not working properly, would I still be able to control the pit? if so, it's possible that the Pi has gone to Pi heaven. this may be a dumb question, but the control function works fine.

I just tried configuring for a third wifi access point I have, with the same negative results.

here is the relevant part of the config file in case I have something wrong (WPA2 password is not shown here)

##
## wifi configuration
##
# SSID (network name) -- Case-sensitive!
wifi_ssid='Office iMac'
# Password for encryption -- Case-sensitive!
wifi_password='**********'
# Encryption mode psk2 (WPA2-PSK default), psk, wep, none
wifi_encryption=psk2
# Mode ap (Acess Point) or sta (Client mode, default). Must be lowercase!
wifi_mode=sta
# wifi channel, only used in AP mode
#wifi_channel=6
# wifi band 5 GHz (5) or 2.4 GHz (2), only required in AP mode
#wifi_band=2
 
Last edited:

Bryan Mayland

TVWBB Hall of Fame
Yeah the whole grill control operation has nothing to do with the Pi, so the HeaterMeter will function and control the grill and display temperatures without even a Pi connected.

Your config snippet looks good to me. You can watch the LEDs on the Pi itself (not the HeaterMeter's LEDs) to get an indication of if it is working at all. The LEDs will be on steady for a second, then flash like crazy as the kernel is loading for another second or two. Then it will become a steady fast flashing (preinit) then a slow steady flashing (services starting) and finally will go steady again (either on or off, but not blinking any more). At that point, it will be connected to the wifi within 5 seconds if things go well. If you're not getting this sequence of LED flashing, then:
  1. The SD can't be read
  2. The SD firmware is for the wrong target or is too old a version
  3. The Pi is not happy for some reason
In that first step where all the LEDs come on at first, the Pi itself can flash an error code as well. That happens as soon as you plug it in.
 

Ken Ba

New member
Bryan--thanks for the info.

I removed the Pi from the HM board and loaded a Raspbian image to make sure the Pi and the wifi dongle worked. passed that test.

reinstalled the Pi, restarted, no indication of IP address.

then I downloaded the latest development snapshot, configured the config file, and also tried the "reset configuration" option on the HM display, (yes, I'm an engineer and should know better than trying two troubleshooting steps at once) and now all is well.

ken
 

Top