Results 1 to 6 of 6

Thread: Feedback on first cook?

  1. #1
    New Member
    Join Date
    Dec 2018
    Location
    MSP
    Posts
    20

    Question Feedback on first cook?

    Threw two pork butts on the Pit Boss yesterday for a maiden run with my HeaterMeter. Turned out pretty well, was happy with how the HM + damper worked.

    Graph below. A little after 18:28 when things stabilized is when meat was put on. About 5 hours in when you see the other blips it was me foil wrapping and adding hot water to the pan. After that, i went to bed. A lot of oscillations but was near my final target temp (no meat probe used this time) by 05:30 when I probed it manually. Any input, concerns, etc?

    My existing TC thermometer is slow to react, I used a thermistor as well (green line barely visible) to compare the two; it was always at least 90 seconds ahead/more quick to react.


  2. #2
    TVWBB Guru Steve_M's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    2,090
    Did you have enough fuel for the cook? The oscillations are somewhat similar in size, but the amount of blower needed to recover the temps appears to be an upward saw-tooth pattern. To me, this looks like it struggled a little more each time to recover the decrease in temperature.

    What PID, Fan and Servo settings are you using?

  3. #3
    New Member
    Join Date
    Dec 2018
    Location
    MSP
    Posts
    20
    I never had to replenish the fuel; see below for picture of final after everything cooled down.

    Settings currently are I believe default:
    P = 4
    I = 0.02
    D = 5
    Fan=Voltage, On Above=0%, Min=0%, Max=30%, Startup=100%

    - I find it interesting that the difficulties started so close to when I closed the lid for the final time overnight. I wish I would have seen that prior to sleeping so I could have tweaked the PID settings.

    - I wonder if my slow reacting TC made things worse than they would otherwise be. Blower ran longer than needed, then it ramped temp, to which is shut down, rinse repeat. Can I tune through that?

    Reading more on tuning here based on Gary V's comments: https://tvwbb.com/showthread.php?737...l=1#post853478



  4. #4
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,758
    Yeah 90 seconds to react to a temperature change would make it pretty difficult to control. You might try increasing your D term (try doubling it) to compensate. Even taking it to 12 or 15 might be OK since all the small temperature fluctuations that make the output go crazy with a high D are being smoothed out by the slow-reacting thermocouple.
    I'm that HeaterMeter guy what ruins everybody's free time.

  5. #5
    TVWBB Member
    Join Date
    Mar 2017
    Location
    Out West
    Posts
    50
    it looks like to me that you have too much "P" and "I". Since this is a ceramic grill, make sure it is sealed tight. Now smoke leaking out dome gasket and gasket that seals the main grill cover to base.
    try these settings if you want. These are for a Adapt- A -Damper. Should be good starting point for Tom Cole style dampers and possibly the RD3 damper. For Microdamper, these might be good starting values, but I guarantee you will need to mess with how you integrate the fan into the control. Small fan, with low pressure and more internal restriction in the damper you will need to adjust for. I do have a Microdamper and I have tuned it to work pretty well, but my ceramic controls much tighter with blower based dampers also cook with ceramic plate between coals and food. Keeps temp even more steady and reduces spikes from the coals. I also do not place my control, pit probe, on the grate. Try to keep it at the same level and in center of grill as the grill mechanical temp probe.
    P 2.75
    I 0.0035
    D 6
    fan voltage
    fan on above 0
    fan min% 10
    fan max 5% 25
    startup max% 70

    Good luck

  6. #6
    New Member
    Join Date
    Dec 2018
    Location
    MSP
    Posts
    20
    Quote Originally Posted by Gary V View Post
    try these settings if you want. These are for a Adapt- A -Damper.
    Thanks Gary. I also have an Adapt-a-Damper so will experiment with Bryan and your suggestions next cook. Will be a couple weeks before I fire it up again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •