Results 1 to 2 of 2

Thread: Servo issues

  1. #1
    New Member
    Join Date
    Jan 2015
    Location
    Chicago
    Posts
    3

    Servo issues

    Hey,

    I finally got my first heatermeter put together and I am testing the fan and servo, the fan works great but my servo is going crazy. I tried two different servos to make sure it wasnt the problem. When open 100% it just moves like 1 degree back and forth really quickly for about 3 seconds, stops, then like 5 seconds later it does it again. It seems to do the same thing at 0% open. I checked the voltage at on the 5v line and at 100% open it reads 4.68v while the servo signal reads .47v. At 0% open the 5v is at 4.72v and the signal line is .27v. Does anyone have any idea what might be causing this?

    Thanks,
    Dan

  2. #2
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,738
    Have you tried putting a capacitor across the 5V/GND at the servo end of the connection? This can solve a lot of problems of the servo jittering or outright jerking around. I've had success with as little as a 0.1uF ceramic, but I think a 100uF electrolytic is more commonly used here. 6.3V or higher rated. None of my dampers have the capacitor but it is somewhat common to need one. I've checked the PPM servo signals on my scope and they're beautiful so I'm not sure why it is a problem for the servos apart from being at the end of a somewhat long cable.
    I'm that HeaterMeter guy what ruins everybody's free time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •