Results 1 to 2 of 2

Thread: OPKG - Installing Git and Python

  1. #1
    New Member
    Join Date
    Nov 2018
    Location
    Melbourne, Australia
    Posts
    3

    OPKG - Installing Git and Python

    Hi.

    I'm a new owner of a Heatermeter v4.3 and kicking off a little IoT project to enhance some of the features.

    I'm wanting to install Git and Python packages to help facilitate with some mods but have an issue with installing packages. Any guidance from anyone who has attempted this before would be much appreciated.

    Results:
    root@HEATERMETER:~# opkg update
    *** Failed to download the package list from http://downloads.lede-project.org/sn...er/Packages.gz

    root@HEATERMETER:~# wget http://downloads.lede-project.org/sn...er/Packages.gz
    Downloading 'http://downloads.lede-project.org/snapshots/packages/arm_arm1176jzf-s_vfp/linkmeter/Packages.gz'
    Connecting to 148.251.78.235:80
    HTTP error 404

    Browsing to http://downloads.lede-project.org/sn...1176jzf-s_vfp/ I see no "linkmeter" folder.

    Has the package list been moved? What's the best package library I can use?

    Thx.

  2. #2
    New Member
    Join Date
    Nov 2018
    Location
    Melbourne, Australia
    Posts
    3
    An update, after modifying /etc/opkg/distfeeds.conf to the below i now can install some pacakges.

    src/gz reboot_core http://downloads.lede-project.org/sn...m2708/packages
    src/gz reboot_base http://downloads.lede-project.org/sn...jzf-s_vfp/base
    # src/gz reboot_linkmeter http://downloads.lede-project.org/sn..._vfp/linkmeter
    # src/gz reboot_luci http://downloads.lede-project.org/sn...jzf-s_vfp/luci
    src/gz reboot_packages http://downloads.lede-project.org/sn...s_vfp/packages

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •