Results 1 to 5 of 5

Thread: How to access HM when away from home network

  1. #1
    New Member
    Join Date
    Sep 2018
    Location
    Brisbane Australia
    Posts
    10

    How to access HM when away from home network

    Hi guys I just built my new HM 4.3.4 all set up and working great. Tuning the PID which isnít perfect yet. Running Microdamper on a KJ Classic.

    My issue is when I am away from the home network I can access the HM. Is there something in the settings I need to do?

    Any help appreciated.

  2. #2
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,521
    There's nothing that needs to / can be done from the HeaterMeter itself, a request coming from outside the home network is served just as it would be locally. You've got to do some configuration on your home router to get traffic to the device though, and there's no way to explain the steps exactly because every single router does it differently.

    There are other threads about this with more detailed explanations but there are essentially two things you need to do:
    • "Cut a hole in the firewall" -- Forward a port from the outside and forward it to HeaterMeter. Choose a random port number (between 1025 and 65534), say 12345. On the router set it to forward that port to the HeaterMeter hostname on either 443 (for encrypted) or 80 (unencrypted).
    • "Be able to find your device" [optional] -- You can now access your HeaterMeter from the internet using the router's outside IP address and that port you selected like https://24.54.93.256:12345/. That's not exactly convenient to remember, so many routers support dynamic DNS services like No-IP. Create an account and pick a name and follow their instructions to make sure it stays updated. Then you can just go to, for example, https://downundahbbq.hopto.org:12345/
    I'm that HeaterMeter guy what ruins everybody's free time.

  3. #3
    New Member
    Join Date
    Sep 2018
    Location
    Brisbane Australia
    Posts
    10
    Thanks mate I have created an account with no-up will have a crack at the port forwarding tonight. Appreciate the help and understand it is a broad question.

    Cheers

    Kyle

  4. #4
    New Member
    Join Date
    Sep 2018
    Location
    Brisbane Australia
    Posts
    10
    Hi Bryan I have set up my No-Ip address and have got my router to port forward which I have tested and works. The only issue I am coming across is my Heatermeter IP address keeps changing so the host name needs to be continually updated with the new IP.

  5. #5
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,521
    If you're referring to the HeaterMeter's local IP address on your network, this can be remedied by assigning the device a "static DHCP registration" or "static lease" so that your router gives it the same address each time it asks for one. If you dig around in your router's settings, there's usually a list of these somewhere where you add the MAC address (looks like 11:22:33:44:55:66) and the IP address you want to give it. From then on, the router will give the same IP to the device each time thus solving all problems once and for all!

    If you mean that the router's external IP address keeps changing and you have to keep updating No-Ip, then look in the router's settings for a way to automatically notify No-Ip with the update each time it changes. It's usually listed in the router as DDNS.
    I'm that HeaterMeter guy what ruins everybody's free time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •