Results 1 to 7 of 7

Thread: Heatermeter AP Mode

  1. #1
    TVWBB Member
    Join Date
    Oct 2013
    Location
    United States
    Posts
    41

    Heatermeter AP Mode

    I am looking for some tips and tricks for connecting to the HM directly. I use the Edimax adapter and have a "headless" HM (I built it without the screen and made a more compact case for it.)

    I've had my meter for quite a few years and we've had our ups and downs. My biggest problem with my HM has always been connection issues. I have an SD card fully setup for connecting to my local SSID with a DNS server to connect remotely. I had 8 days of uptime and everything is great. However, I cannot get my HM to connect by wire or through the default heater meter AP.

    Any suggestions on what could be wrong?

    -Michael

    EDIT: A summary

    Latest Snapshot - March 27 2018

    Download latest snapshot on 4GB card (Heatermeter AP)
    Result: No Heatermeter AP being broadcast, but I am able to connect directly via LAN

    Download latest snapshot on 4GB card (Custom AP)
    Result: No Kadersmeter being broadcast, but I am able to connect directly via LAN

    Download latest snaphot on 16GB Card (Client mode)
    Result: Able to connect to SSID and able to connect VIA LAN (if I disconnect Edimax and restart HM)

    Use Snapshot downloaded on March 25 on 8GB card (Client Mode)
    Result: Able to connect to SSID but unable to connect to LAN
    Tried to update firmware using .gz file - HM will not communicate to Pi
    Must have done firmware wrong, was able to restore using Bundled firmware in /lib/firmware

    I'm still not sure why I have no ability to connect directly. My wifi adapter works. Everytime I connect via LAN with an AP snapshot downloaded the wwan looks dormant (RX: 0 B (0 Pkts.) TX: 0 B (0 Pkts.))

    My end goal is to either have my HM default to AP mode when wifi is not available or just have another build setup to do AP mode. I figured the latter is a simpler approach.
    Last edited by MKader; 04-08-2018 at 08:00 AM.

  2. #2
    TVWBB Emerald Member
    Join Date
    Apr 2013
    Location
    midwest
    Posts
    3,414
    My first thought is ditch the Edimax and try an adapter with a different chipset, the Edimax is known to have AP mode issues with certain releases. I've been using an RA5370 based wifi and haven't had issues connecting (or reconnecting) in any mode.

    As for wifi mode selection, you have to select that manually so your options are to do that through HM Config or the other option is to use a thumb drive. If you put a config file on a thumb drive and have it plugged into the HM at bootup the HM will "import" the config from the thumb drive, this will overwrite the current config on the HM. I believe the file name needs to be the same and the config file needs to be in the root directory of the thumb drive. (haven't tested, consult wiki if it doesnt work). So you could make two folders on the thumb drive, 1)Client Mode 2)AP Mode and save the respective configs in each. Copy the desired config to the root folder and boot to load the desired mode... or use two thumb drives, their cheap enough I guess...
    I created the Roto Damper, RD3, HMv4.2 sliding back case, "air-burner" and the "ping-pong" valve in my quest for delicious "set and forget" BBQ.

  3. #3
    TVWBB Member
    Join Date
    Oct 2013
    Location
    United States
    Posts
    41
    Worth a shot. I just ordered a RALINK 5370 based adapter. It's from MK Electronics which is also my initials, so thats pretty cool.

    In theory, could I potentially have both plugged in and setup and could have the best of both worlds on one build?

  4. #4
    TVWBB Member
    Join Date
    May 2016
    Location
    Rochester NY
    Posts
    54
    I just dumped my pi B and Edimax (x2) interfaces because of similar issues. The WiFi would work most of the time, but would drop out, sometimes briefly, sometimes for long periods. Rebooting would not always help and often, when the WiFi dropped, it would take out the LAN as well which made it difficult to debug.

    I switched to a new Pi Zero W and it is now behaving perfectly and it is quite a bit faster. The Zero is nice and compact and would make a great mini-HM headless system, but if you want the LAN interface, perhaps try the new 3B plus or whatever they are calling the full size pi with onboard WiFi. Either way, if the new dongle doesn’t solve your issue, I would suggest a new pi.

  5. #5
    TVWBB Emerald Member
    Join Date
    Apr 2013
    Location
    midwest
    Posts
    3,414
    MK, actually that is a third option which I failed to mention that may suit your needs. Setup the Edimax for client mode (where it works well), and setup the 5370 for access point mode, and then boot with the adapter that suites your required mode.
    I created the Roto Damper, RD3, HMv4.2 sliding back case, "air-burner" and the "ping-pong" valve in my quest for delicious "set and forget" BBQ.

  6. #6
    TVWBB Member
    Join Date
    Oct 2013
    Location
    United States
    Posts
    41
    I got in the new wifi adapter, loaded the latest snapshot, hooked everything up and it's good to go!

    I'll probably keep 2 sd's and 2 adapters for each setup, unless someone convinces me otherwise.

    -MK

  7. #7
    TVWBB Emerald Member
    Join Date
    Apr 2013
    Location
    midwest
    Posts
    3,414
    Sounds like a plan, glad the new adapter worked out for you!
    I created the Roto Damper, RD3, HMv4.2 sliding back case, "air-burner" and the "ping-pong" valve in my quest for delicious "set and forget" BBQ.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •