Page 15 of 15 FirstFirst ... 5131415
Results 141 to 144 of 144

Thread: The LinkMeter Snapshot and YOU

  1. #141
    TVWBB Wizard
    Join Date
    Apr 2011
    Location
    Puyallup, WA
    Posts
    1,630
    Quote Originally Posted by Bryan Mayland View Post
    I put a new AVR Firmware snapshot up this morning. I did a pretty big refactor on the internals of the device Menu system and moved a lot of stuff into the classes where they belong. It started as just me adding the ability to have more than one dynamically updating display in the HeaterMeter devices menus, which was the probes / output home display we all know. As I started to implement it I realized it was a bit of a mess so what could have been done in an evening stretched into breaking the existing code, then procrastinating for a month because the code was so broken that I didn't want to deal with it. In addition to adding more functionality, a few bugs were found and squashed, and it should be easier to extend now. The downside is that a ton of code got moved around or rewritten so there's a chance I have broken something in the LCD display / buttons / menu system. I've tested everything I can think of and it all seems to work the same as it did before the changes, but I have not bundled this into the Pi firmware image just yet. I'll wait to hear if anything is broken for a while.

    This does add a new troubleshooting feature to the HeaterMeter device itself, the Internal Diagnostics Display. Full information is in the documentation, but to enter the hidden menu, go to the "Manual fan mode Yes/No" menu on the device and hold the left button until the display switches to the diagnostics info for Probe0. Here you'll find the raw ADC readings, probe type, bandgap information, noise values, measured blower output voltage, and button readings.

    I've also fixed the bug where when unplugging a thermocouple that's at a temperature less than ~430F, it would publish one erroneous reading around 430F before actually returning to OFF.

    To install the latest AVR Firmware, just go to LinkMeter -> AVR Firmware in the webui. Select "From Online Repository" and select the most recent snapshot which is 20190327B.

    I noticed that bug of the temperature, and I just thought I had an soldering issue, lol

  2. #142
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,682
    Quote Originally Posted by John Bostwick View Post
    I noticed that bug of the temperature, and I just thought I had an soldering issue, lol
    haha it used to be broken initially, then it worked properly, then the hard noise limits were removed so it stopped working, then I fixed it, then I broke it again when working on the issue where it would get stuck transitioning, and now it is working properly again! It has been on my todo list to fix for like 6 months now and I noticed it every. dang. time. I unplugged a thermocouple. Finally got the menu changes done and it took like 2 minutes of looking at the code, 5 minutes to make the change, then 15 minutes of testing.

    The other fix that's coming soon is that you currently can't scroll backwards through the probes on the device LCD home screen if one of them is unplugged. The updates to the menu system should make this trivial to do, although first I need to unwind the way it is done now (chaining menu transitions) first which will take considerably longer to do. I'm just happy to have time to start knocking these things out as I'm between jobs right now. Contractors are sort of always between jobs though!
    I'm that HeaterMeter guy what ruins everybody's free time.

  3. #143
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,682
    Updated the AVR Firmware to 20190418B
    • Fixes LCD backlight menu item which would visually reset to old value every time you changed the value (it would save it properly, it would just blink NEW -> OLD)
    I'm that HeaterMeter guy what ruins everybody's free time.

  4. #144
    TVWBB Pro
    Join Date
    Apr 2014
    Location
    Montana, USA
    Posts
    686
    You da Man, Cap!

Page 15 of 15 FirstFirst ... 5131415

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •