Results 1 to 4 of 4

Thread: New HM! Hardware great! Software, help...

  1. #1
    New Member
    Join Date
    May 2013
    Location
    Texas
    Posts
    5

    New HM! Hardware great! Software, help...

    Hi all.. First off I just finished building the HM .. Great project, lots of fun! I love the custom 3D printed case, wish I had one of these for the kegbot I just built. So I completed the build, powered things up and got the expected no probe message on the display. Then I got ahead of myself.. I wired up the pi to my Mac and fired up the browser. As expected I got the IP address on the screen and the cool flames on the browser. I went straight to the network settings and changed the mode to DHCP. Now I am stuck.. At boot I see the HM on the network between the mac and the HM. The browser connects then a few seconds later the HM drops off the network. I have tried erasing the SD card and starting fresh but the same pattern occurs. I tried booting into the console but after the file system is mounted the pi does not seem to drop into console mode. I can see the keyboard detected during boot but not response to my pounding of the keys, maybe it is the Mac keyboard, not sure... Any suggestions? I am pretty comfortable with Linux, command line, etc but I am stumped on this one.. Really appreciate any help anyone can provide...

  2. #2
    New Member
    Join Date
    May 2013
    Location
    Texas
    Posts
    5
    Just read about the norestore option at boot. I will give that a try tomorrow ... Should have read through the docs before I posted...

  3. #3
    TVWBB Honor Circle Bryan Mayland's Avatar
    Join Date
    Apr 2010
    Location
    Tampa, FL
    Posts
    4,739
    I've actually heard from someone else that the mac keyboard doesn't work either. I'm surprised that it isn't a standard USB HID device, but doing some searching says that it requires a special HID driver hid_apple which there's no OpenWrt package for. I might make one at some point.

    Do you also have wifi enabled on the Pi? That could be why it works then doesn't. The wired connection comes up faster than the wireless, and when the wireless comes on you can't connect any more.

  4. #4
    New Member
    Join Date
    May 2013
    Location
    Texas
    Posts
    5
    I forgot to bring home a keyboard from work so I did not get to try out a non-Mac keyboard tonite. I will try to remember tomorrow and let you know. I was able to get things back to where I was before I messed with the network settings. I am now able to see the HM on the network between my mac and the pi. I should get my wifi dongle tomorrow so I will wait until then to mess with things further. Good to have it back online, cant wait to get it on wifi so I can really start playing with it. I still need to figure out what I am going to do to mount my fan, but I feel like I am back on track now. Thanks for the project, this is really a fun one! Cannot wait to get my first smoke going ...

Similar Threads

  1. Ace hardware cowboy lump sale
    By Andy V in forum Barbecuing
    Replies: 2
    Last Post: 05-18-2013, 07:57 PM
  2. Stoker has IP address, can't log into it? (Apple hardware)
    By Stan in forum Automatic Temperature Control Systems
    Replies: 36
    Last Post: 06-27-2011, 03:51 AM
  3. Royal Oak sale Ace Hardware
    By John Furdyn in forum Barbecuing
    Replies: 18
    Last Post: 05-19-2008, 08:48 AM
  4. Ace hardware charcoal sale
    By John Furdyn in forum Barbecuing
    Replies: 26
    Last Post: 04-29-2008, 08:14 PM
  5. Zinc Coated Hardware, Paranoid please help!
    By Jonny K in forum Barbecuing
    Replies: 3
    Last Post: 12-19-2006, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •